Game gets error 'Application was unable to start correctly (0xc000007b)' when starting

GOG Version - setup_everspace_2.3.0.5.exe, (current download on my library as of today)

GeForce 660 Ti, Windows 7 Ultimate 64-bit, game is being installed on a secondary SSD not on the C: drive as I keep all games installed on their own drive.

I've done some preliminary testing based on initial posts:

Restarted. Uninstalled and restarted and reinstalled. Uninstalled, Redownloaded, restarted, reinstalled.

Manually installed the Unreal prerequisites with it uninstalled, updated all windows updates plus a graphics driver just in case. Restarted between each of course. Nothing present under Restore Hidden Updates.

I attempted installing on the C: drive as well, same error occurred. RSG folder is entirely empty, no log data in place.

Any theories would be appreciated, prepared to get any necessary details you'll need. This seems too widespread to be anything complicated, I must be missing something basic, just not sure what.


  • gaelstromgaelstrom Member Posts: 4
    A quick google search of the error too and it determined a Direct X error, I did a dxdiag and I have Direct X 11 on my system, which it seems is the latest version for Windows 7. Other games having no issues running after some general tests, Dishonored 1, Skyrim, and Homeworld Remastered all fine.
  • ROCKFISH_SvenROCKFISH_Sven Moderator Posts: 94
    edited December 2016
    As far as I can see you all you can be sure of is, there is *SOME* dependency problem, probably some 32/64 bit mismatch. Might be Direct X but as likely (or maybe even more likely) a problem with the Visual c++ Runtime.

    1. Try starting the Win64 Binary manually: ...\EVERSPACE\RSG\Binaries\Win64\RSG-Win64-Shipping.exe
    2. Try starting the Win32 Binary manually: (yes, although you have a 64bit system) ...\EVERSPACE\RSG\Binaries\Win32\RSG-Win32-Shipping.exe
    3. If both won't work my recommendation is to use the Dependency Walker to identify the .dll that can't be loaded (start the RSG-Win64-Shipping.exe from within the walker and then search for files marked red in the walker. Afterwards make a screenshot and send it here.
  • gaelstromgaelstrom Member Posts: 4
    Absolutely superb suggestion, using the 32-bit pathway seems to have worked. This is rather odd too, for whatever reason my computer has never shown more than 4GB RAM even though I have a fresh Win7 64-bit install with a motherboard that can handle it and 32GB of actual ram in the sticks (Tested individually and all work on their own and are matched pairs) so I wouldn't be surprised if this somehow related to that mystery. Not one person I know has managed to figure it out and I hope my plans for new hardware will solve it outright later next year.

    If you happen to have any followup suggestion I can attempt for the 64-bit pathway with C++ runtime I'd like to attempt it, but otherwise I have a functional 32-bit pathway, so again I very much appreciate it.

    Game is challenging as -BEEP- as advertised, but frustrating for the right reasons (aka I suck and died to the first surprise capital ship arrival as expected). Hopefully my aim improves and the perks help. Thanks for the assist!
  • gaelstromgaelstrom Member Posts: 4
    I forgot to post that I also did the dependency checker and the screenshot, that may help a bit too.
Sign In or Register to comment.