no control spinning

Hello, first launching the game installed from
the ship spins while doing nothing direction top right. I can stabilize it somewhat by constantly moving the mouse in the opposite direction. Nothing playable here. I don't want to use the mouse, I want to use my hotas X52 pro.
While spinning most buttons from the hotas seem to work, except I have no throttle, and neither yaw, pitch, roll.
I have tried to reset the controls. my mouse is okay in other games and situations, my hotas works perfectly in other games.


  • drlexdrlex Member Posts: 4
    spin stops when unplugging saintek x52 pro.
    When the hotas is plugged, the spin starts moderate then go faster. The dead zones are correctly setup, I have checked. The game seem to work with keyboard and mouse, when hotas is unplugged.
  • drlexdrlex Member Posts: 4
    tried to delete *UserFolder*/AppData/Local/RSG/Saved/Config/WindowsNoEditor/ (with no effect)

    I have spotted something strange, each control I wish to set one of the analog axis of the hotas, it always set it to axis 3 so it is impossible to setup more than one axis. It's like one axis is constantly stuck at 100%.
  • drlexdrlex Member Posts: 4
    well I found the problem, that was one of the dials on the hotas that was set not in the middle but stuck at 100% or 0% so each time I wanted to assing an axis that was the one registering. Everything work fine now.
  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    Glad you were able to solve the problem
Sign In or Register to comment.