What's Up With Xbox One Controller Support On PC?

ShwingShwing Member Posts: 3
Just bought the game, and no matter what I do none of the controller options seem to change anything. Y axis won't invert / crosshair won't remain stationary etc.

Am I missing something?

Thanks.

Comments

  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,216
    Hi, I've not heard of the issue before, I'm assuming that it's either some conflict with Steam Big Picture mode/controller configuration, some binding conflict or you're probably using the wrong menu / wrong checkboxes.

    Please try the following:
    - Disable Steam controller support for this game
    - Reset all bindings to default. This only really works reliably by deleting two config files, the Input.ini and the GameUserSettings.ini while the game is closed. They can be found at C:\Users\{YOUR_USERNAME}\AppData\Local\RSG\Saved\Config\WindowsNoEditor Note that the AppData folder is hidden by default, you can easily access it by typing %localappdata% in a Windows explorer address field
    - Then go to options->controls->controller and check if toggling "Invert Y-Axis" and "Centered Crosshair" have the desired effect
  • ShwingShwing Member Posts: 3
    Thanks for your reply Andi.
    I solved all the controller issues by downloading a user config from the Steam community.
    Surely the official controller settings should've worked as opposed to replying on a community member?
  • camelchildcamelchild Member Posts: 1
    Issue to this is Steam has a default profile for Everspace where it assumes you're using a Steam controller - the one with the touch pad for mouse input.

    So your Right Stick ends up registering through Steam, as a mouse input - hence why the crosshair moves everywhere, but you don't.

    Changing your controller settings with Steam needs to be done when you are running Everspace; Shift + Tab to bring up your Steam Overlay and click on the controller settings link at the top right hand part of the overlay (small link text). The next window may not automatically appear in from so dig around in your taskbar for it, but you should find a steam setup window different to what you would normally find when going through Steam's Settings > Controllers > General Controller Settings. You should see your right stick has Mouse input set, click on the icon to access more settings and change this back to Joystick Input.
Sign In or Register to comment.