Everspace on Stadia failed to launch! Please help!

Hi Everspace support:
The game on stadia has failed to lauch. I am stuck at the black loading screen with "everspace" in the middle, and "rockfish games" at the bottom right.
the steps i have taken to isolate the problem are:
1. all my other games worked, only everspace stuck at loading.
2. 2. I have tried different browser, different machines (PCs, laptop, ipad, chromecast). all yield the same.
3. 3. I also tried two networks (home and office), all the same problem

I spoken with Stadia support. and they also recommend brining this to you attention as well. please help.


  • teddarcheeseteddarcheese Member Posts: 1
    Having this same issue. Stadia version have tried to play it on two devices, two internet connections. Loving the game and really hoping that it comes back up soon.

    Also would absolutely love a Stadia version of Everspace 2! Just found the games and enjoying it.
  • tamic007tamic007 Member Posts: 2
    Anyone having the same issue? I have contacted Stadia, and they said they in-turn contacted rockfish. but so far no solution yet. I was refunded with my purchases on this game tho.
  • RonaldLongRonaldLong Member Posts: 1
    Exact same issue; haven't been able to get past splash screen on Stadia since early November. I also reached out to Stadia support, and they suggested reaching out here. Would appreciate any advice on how to rectify this.
Sign In or Register to comment.