Joystick Binds

Game recognizes and lets me bind buttons on my joysticks. VKB Gladiator Nxt. Once bound everything works great. Until I quit and log back in. When going back to the key-bind section it shows my binds are still there, but in game they stop working. If I rebind everything it works again, until I quit and log back in. So right now I have to start game, spend 5 minutes rebinding my already bound keys to use my sticks.
Also one of the HAT sticks is being considered an axis and I can't bind any normal functions i.e. target nearest to any of it's directions.

Comments

  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    Hi, the HAT thing is normal, unfortunately, as these are always axes and deliver axis inputs to us.

    Regarding the other problem: We've heard it a few times now, but I am unable to reproduce. I'm currently very busy answering on forums and filing bug reports in our system, so it will take some time until I can look into this. I think it will be hard to debug, as it does not seem to happen for every one and right now I have absolutely no clue why it is happening. I think I'll set up a thread some time next week or the week after on the steam forum asking a few players with that problem for more feedback so that maybe I can get an ideat what could be causing the problem
  • koztantkoztant Member Posts: 7
    I appreciate the reply. I did try a few things to see if it was a conflict. Pulled all peripherals off the PC and only used the sticks. Deleted the input.ini and tried redoing all the inputs from scratch. Copied an input.ini file while the sticks were working and tried to 1. Copy it back to the game file while the game was working, and 2. Copy it back to the file before I started the game. Tried to make the input.ini file read only.
    Unfortunately nothing worked. Also 2 of my 3 HAT switches bind fine as regular inputs. I only have 1 HAT switch that gets confused as an axis.
  • TokuToku Member Posts: 1
    Heya this bug happened to me on day one, it is incredibly frustrating.

    I'm playing with a separate throttle, stick, and pedals. The stick and pedals stay bound, however *every* input for the throttle converts over to "JSO_Throttle-". For example Thrust axis goes from "Throttle - HOTASWarthog-0 Axis 2" to "JSO_Throttle-" and turns red.



    I have to rebind everything on that device in order to play *every* time I launch. Please do look into this, it's a real bug, and it's incredibly frustrating. If there is any information hardware wise, log wise, whatever, that would help in diagnosing this I'm happy to provide it.
  • koztantkoztant Member Posts: 7
    Mine's a little different. As far as I can tell the stick name in the panels doesn't change. When I rebind it, it still stays the same, but works.
  • ManuLHanManuLHan Member Posts: 9
    edited January 31
    I have the same issue.

    My observation is that by some reason joystick axis drop from config after the next launch of the game.

    2-Joystick + Pedals setup:
    Gunfighter Mk.III SCG «KOSMOSIMA» (Right)
    Gunfighter Mk.III SCG «KOSMOSIMA» (Left)
    VKB T-Rudder Pedals (not used in general setup, but noticed that ES2 doesn't see them: nothing happens when I press them in attempt to set as one of axis in settings)


    Steps to reproduce:
    1. Setup controls ingame.
    Here is what I see in game settings - assigned joystick axis have numbers after them:


    And here is a part of input.ini file (pitch axis as example):
    KeybindingsConfig=(Action=Pitch,ActionName="",AxisName="Pitch",Category=0,bIsAxis=True,Key1=JS0_VKBSimGladiatorNXTR _Axis1,Key1Mod=None,Key2=None,Key2Mod=None,Scale=1.000000,DeadZone=0.100000,Sensitivity=1.000000,Exponent=1.000000,bInvert=True,DisplayName=NSLOCTEXT("KEY_BINDINGS", "KEYS_PITCH_AXIS", "Pitch axis"),GroupName="Joystick")

    2. Relaunch the game.
    After openning controls, I see that there are no axis on joystick bindings.


    Same in config file:
    KeybindingsConfig=(Action=Pitch,ActionName="",AxisName="Pitch",Category=0,bIsAxis=True,Key1=JS0_VKBSimGladiatorNXTR,Key1Mod=None,Key2=None,Key2Mod=None,Scale=1.000000,DeadZone=0.100000,Sensitivity=1.000000,Exponent=1.000000,bInvert=True,DisplayName=NSLOCTEXT("KEY_BINDINGS", "KEYS_PITCH_AXIS", "Pitch axis"),GroupName="Joystick")



    Same issue with all joystick buttons, not just axis.

    Update: (2021.01.30) tested in current experimental build. Problem solved for my case. Bindings are all in place after game restart.
  • koztantkoztant Member Posts: 7
    So may have found a work-around. I changed my sticks name in Windows Registry. Link to page/description
    https://www.isrtv.com/forums/topic/25278-how-to-rename-peripherals/
    Basically go into your registry and change your sticks OEMName to something else. I have VKB Gladiator Nxts. I simply changed them to VKBR/VKBL did a simple axis bind, left game, and checked if it stuck. And it was still bound when I reloaded the game. Simple summary of what to do.
    Win-R HKEY_CURRENT_USER\System\CurrentControlSet\Control\MediaProperties\PrivateProperties\Joystick\OEM\
    Click through all the files, you'll eventually see your stick's name next to the registry value OEMName. Right-click and modify, change the name to something shorter.
    AS ALWAYS PLEASE EXPORT A BACKUP OF YOUR ORIGINAL REGISTRY FILE just in case, or if you're worried then please don't mess with your registry files. But so far works. Will post again once I get time to do a full rebind and test.
  • koztantkoztant Member Posts: 7
    edited February 6
    Re-bound everything. Bindings carried through multiple play sessions. Read another post about the issue could possibly be a name length issue, and it seems to be true. Name's too long won't stick I'm guessing. Maybe setting the display field to use a generic device 1, device 2, etc. instead of the inputs full name might help with the issue?
Sign In or Register to comment.