Controller Problems

I am trying to return to Everspace after a long time before E2 comes out and I've tried to go back into the game and the controls for controllers are ALL messed up. Is there any fix? I tried using both xbox1 and ds4 controllers and both have the same issues:
- Even setting sensitivity to zero feels WAY too sensitive
- Invert y-axis works in WEIRD ways. It doesn't apply at all when stationary but when activated it kicks in under thrust only, and doesn't really seem to work perfect then, plus that just makes you fly around drunk
-The mouse cursor shows up in menus when i select things with the controller, alt+tabbing out of the game locks the mouse cursor in the center of the screen

I never had any of these issues when I originally played the game. Most of my hours were probably in prerelease of the game I had so much fun. I'd really like to get back into the game but it's totally unplayable and was making me think I had lost the ability to play until I methodically changed options and compared results. I only like to play with a controller bc M+KB feels unnatural to me for flight games which (to me) make more sense with a stick, plus I enjoy being able to sit back away from my desk with the controller. Can anyone help?

This has been posted on steam discussion in bugs and tech problems as well. I've since disabled any desktop configurations I had on the controllers but that didn't help. I want to play my old favorite game so bad!

Comments

  • johnweythekjohnweythek Member Posts: 6
    Thanks! You already fixed it over on the steam discussions!
  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,203
    Ok, cool, so if anyone is reading this, this was my answer on steam which solved the problem:

    It sounds to me like Steam controller configurations are messing up our controls. I think they used to only apply in Big Picture mode, but at some point there was a steam client update and now they seem to apply as default.

    Could you try forcing them off and see if this fixes everyting for you?
    Right-click on Everspace in the steam client library and select Properties->General and there should be two checkboxes at the bottom:

    Steam Input Per-Game-Setting
    Use BPM Overlay When Steam Input Is Active Per-Game Setting

    Set them both to "Forced Off" and see what happens
  • johnweythekjohnweythek Member Posts: 6
    Thanks for getting back to me so fast! Even just getting back into the old game! Especially while you're definitely busy making your new one! You're in that perfect developer spot of being small(er) and having time for people yet able to crank out seriously quality content. Whether it was the 1st game I've enjoyed since pre-release or in bringing us content updates and even a playable demo of your next release. This is why I've owned the game since before it was out, bought it a second time for my Switch, and am refreshing my skills on the old title again for preparation for Everspace 2!!! Rockfish are the best!
Sign In or Register to comment.