BUG: Joystick Z Axis Lock

PeterKanePeterKane Member Posts: 4
edited December 2019 in TECHNICAL SUPPORT (ES2)
I encountered bug.
I playing with dual joysticks setup (X52 Pro and Thrustmaster 16000M)
X52 Pitch, Yaw, Roll, Thrustmaster X,Y,Z strafe.
When I use a fire button in any of these joysticks Z-Axis in both joystick stopped working.
I have to move the mouse to Z-Axis work again.

I found a workaround by redirecting inputs to one device using vJoy and joystickGremlin, but I wanted let you know.
If you want any help or additional info I'm at your disposal.

Thanks for doing joystick inputs into the demo.




Comments

  • whalemanwhaleman Customer Posts: 8
    Maybe a bit late to bump this, but after setting up my dual sticks with the Everspace 2 beta, I encountered the same issue, only the it's the rotational axis on one stick and the vertical axis on the other that locks up. Using either keyboard or mouse to give some movement input unlocks the axes temporarily.

    Setup:
    Left hand stick - Thrustmaster t16000m - Strafe (horizontal), Hover (vertical) and thrust (twist). Hover locks up.
    Right hand stick - Virpil WarBRD + Constellation Alpha - Yaw (Horizontal), Pitch (vertical) and roll (twist). Roll is the one that locks up.

  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    edited November 2020
    Hi, @whaleman I've been working on some HOTAS presets in the last few weeks and I just tried a dual stick setup with two T16000Ms and did not encounter the problem. There have been quite a frew changes to the keybinding/input system since the version that was released as Beta, so the problem might be gone, but I'd like to take a closer look and maybe try to reproduce the problem in the Beta or the Prototype. So are you able to provide a little more info?
    - Does it matter which button you press to create the issue? Does it happen immediately after you press any button? Or does it only happen with a certian action (e.g. fire primary weapon). Does it happen every single time you hit the respective button? Does it get repaired every time you move the mouse?

    Also, could you maybe upload your Input.ini file here (you should be able to attach a zip file). The one with the setup that has the problem. The file can be found at C:\Users\{YOUR_USERNAME}\AppData\Local\ES2\Saved\Config\WindowsNoEditor You can reach the \AppData\Local folder quickly by typing %localappdata% in a Windows explorer address field
  • whalemanwhaleman Customer Posts: 8


    - Does it matter which button you press to create the issue? Does it happen immediately after you press any button? Or does it only happen with a certian action (e.g. fire primary weapon). Does it happen every single time you hit the respective button? Does it get repaired every time you move the mouse?

    Any button on either joystick triggers the issue 100% of the time. Fire guns, interact, boost, cruise, use items (even when empty), I have yet to find a bound button that does not trigger it. As I trigger the button, the crosshair center on screen and the hover and roll axis are instantly disabled.

    Any keyboard/mouse interaction instantly unlocks the two axis 100% of the time, so even just pressing a key on the keyboard works.

    Attaching input configuration.
  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    Thanks for the feedback. So I tested it with two T16000M in the current build, the beta build and the prototype and did not encounter the problem. But thanks to your description I think I know what's going on. Normally, the crosshair should always be centered when using joysticks/controllers only and also the HUD should display "gamepad buttons". I'm guessing in your case that when pressing a button these are displayed and when moving the sticks the HUD shows keyboard keys instead? Anyway, I think the problem is that for some reason your joystick axes are being treated as mouse input which conflicts with everything. I'm guessing that this is due to some steam controller configuration settings. You should try the following:

    Right-Click on Everspace 2 in the Steam Client, select "Properties" and in the "General" tab, set the "Steam Input Per Game Setting" to "forced off" and the "USe BPM Overlay When Steam Input Is Active Per-Game Setting" to "forced off"

    If this does not do the trick, it could be that you're using some sort of remapping/configuration tool that alters your inputs and I'm curious what happens when not using any tools and just directly using the joystick inputs.
  • whalemanwhaleman Customer Posts: 8
    Changing the settings in Steam did nothing and I'm not running any software to alter the behaviour of the sticks.

    The sticks themselves does not move the crosshair off center, but as long as I don't press any button, any axial input from the joysticks keep the crosshair where the mouse last left it, but like stated above, as soon as I use any button (non-analogue input from the joysticks in other words), the crosshair re-centers along with the loss of hover and roll.

    I did however just notice it applies to ANY button, even buttons not bound to any function in game.

    It's really too low sample size, but the original poster also did have an asymmetric setup with two different joysticks (and with the X52, also a throttle). Maybe this somehow affects it?
  • whalemanwhaleman Customer Posts: 8
    Another thing in common between mine and the original poster's setup is that we have a higher number than usual of analogue axis on the sticks. If I recall correctly, the X52 has at least 6, maybe 7 analogue input axis (X, Y, Z on the stick, throttle, mouse X and Y on the throttle and I think one of the rotaries might be analogue as well) coming through the same USB. The Virpil Constellation Alpha has 6 (X, Y, Z, Thumb stick X and Y and brake lever) while the t16000m only has 4 (X, Y, Z and throttle).

    However this should not be an inherent limiting factor in the Unreal engine, because it works just fine in Everspace 1 :)
  • PeterKanePeterKane Member Posts: 4
    edited November 2020

    Anyway, I think the problem is that for some reason your joystick axes are being treated as mouse input which conflicts with everything. I'm guessing that this is due to some steam controller configuration settings.

    I think that it can be very close to true. What I remember it was like the Fire button was switching the game into another mode (like gamepad or mouse mode) for some reason.
    I can't test right now tips with steam configuration, I will try to find some time during the weekend.
    The problem was when I was using directly the joystick inputs (just default drivers). As I said in the first post redirecting everything with vJoy and joystickGremlin into one input solved the problem for me. But it was not the most elegant solution :)

  • PeterKanePeterKane Member Posts: 4
    edited November 2020
    @ROCKFISH_Andi You were almost right. For me buttons 1-16 on Thrustmaster t16000m switching game mode (HUD etc) to Xbox Controller and cutting some inputs like rolling and leaving others like pitch/yaw, it needs mouse/keyboard input to switch back. HAT buttons, and analog inputs not making a problem. Working instantly, working every time the same way. Even buttons not defined in input config causing problems.
    Switching Steam options as forced off didn't solve the problem for me. Attaching Input.ini file

    Can provide some additional data if needed (record movie or something)
    In Everspace 1 never had issues with the same configuration.
  • PeterKanePeterKane Member Posts: 4
    Controls work great for me now in early access. No major issues.
    I had a small problem with "auto roll" on the gamepad affecting my game, but turning it off solved the problem for me.
    Thanks for a great game. Love you!
    Best regards.
  • whalemanwhaleman Customer Posts: 8
    Same here, issue seems gone now :)
  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    PeterKane said:

    Controls work great for me now in early access. No major issues.

    whaleman said:

    Same here, issue seems gone now :)

    Glad to hear!
Sign In or Register to comment.