Game is impossibly slow with my new computer (v 1.3.5.36556 on steam)

This week I have upgraded to a new computer, a Ryzen 7 2700x, 16gigs of ram and a Radeon Rx 480 4gigs. Normally I should have more than enough to run this game, but it's a slide show as soon as the game start. Music run fine, the mice as well, but everything else is stupidly slow. I did try to change the ini settings but nothing seem to make the game playable. My old computer could run this game just fine (scavenged some of the the parts for this one), but can't play Everspace with the new one. Other games run properly, I don't know what is wrong with this one.

Comments

  • ForavenForaven Member Posts: 121
    Computer Information:
    Manufacturer: System manufacturer
    Model: System Product Name
    Form Factor: Desktop
    No Touch Input Detected

    Processor Information:
    CPU Vendor: AuthenticAMD
    CPU Brand: AMD Ryzen 7 2700X Eight-Core Processor
    CPU Family: 0x17
    CPU Model: 0x8
    CPU Stepping: 0x2
    CPU Type: 0x0
    Speed: 3693 Mhz
    16 logical processors
    8 physical processors
    HyperThreading: Supported
    FCMOV: Supported
    SSE2: Supported
    SSE3: Supported
    SSSE3: Supported
    SSE4a: Supported
    SSE41: Supported
    SSE42: Supported
    AES: Supported
    AVX: Supported
    CMPXCHG16B: Supported
    LAHF/SAHF: Supported
    PrefetchW: Unsupported

    Operating System Version:
    Windows 10 (64 bit)
    NTFS: Supported
    Crypto Provider Codes: Supported 311 0x0 0x0 0x0

    Video Card:
    Driver: Radeon (TM) RX 480 Graphics
    DirectX Driver Name: aticfx32.dll
    Driver Version: 26.20.13025.1004
    DirectX Driver Version: 26.20.13025.1004
    Driver Date: 9 26 2019
    OpenGL Version: 4.6
    Desktop Color Depth: 32 bits per pixel
    Monitor Refresh Rate: 60 Hz
    DirectX Card: Radeon (TM) RX 480 Graphics
    VendorID: 0x1002
    DeviceID: 0x67df
    Revision: 0xc7
    Number of Monitors: 1
    Number of Logical Video Cards: 1
    No SLI or Crossfire Detected
    Primary Display Resolution: 1920 x 1080
    Desktop Resolution: 1920 x 1080
    Primary Display Size: 20.51" x 11.54" (23.50" diag)
    52.1cm x 29.3cm (59.7cm diag)
    Primary Bus Type Not Detected
    Primary VRAM Not Detected
    Supported MSAA Modes: 2x 4x 8x

    Sound card:
    Audio device: SB Recon3D PCIe

    Memory:
    RAM: 16320 Mb

    Miscellaneous:
    UI Language: English
    Media Type: Undetermined
    Total Hard Disk Space Available: 2632102 Mb
    Largest Free Hard Disk Block: 500902 Mb
    OS Install Date: d?c. 31 1969
    Game Controller: None detected
    VR Headset: None detected

  • ROCKFISH_AndiROCKFISH_Andi Moderator Posts: 1,104
    No idea. Is this in VR or in the normal version? Could your try terminating all background applications that might interfere in some way? Have you tried all window modes? Have you tried playing with sound turned completely off?
  • ForavenForaven Member Posts: 121
    edited October 8
    1: Normal version (on steam, under Windows 10)
    2. Did try killing background programs, did nothing.
    3. Windows mode? Like compatibility modes? I have no idea how to do this with a steam game. As for changing resolution or making it full screen rather than windowed; no change.
    4. As for sound, I use a sound blaster card rather than onboard sound, so that may be why sound works normally.

    The only thing I see is some incompatibility of the game with the hardware I have. Every other game I have seem to work normally, Everspace is the only one that is unplayable regardless of what I do.

  • ROCKFISH_AndiROCKFISH_Andi Moderator Posts: 1,104
    Hmm, I don't have a clue - I'll ask around here, but it's strange. With window mode I meant the display mode (window/fullscreen/windowed fullscreen)
  • ForavenForaven Member Posts: 121
    edited October 9
    I still can't get it to work...
  • ForavenForaven Member Posts: 121
    Finally found the problem; My windows 10 wasn't updated to the latest version. Auto update wasn't working properly so I had to manually install the update. But now the game works as it should!
  • ROCKFISH_AndiROCKFISH_Andi Moderator Posts: 1,104
    Phew! Glad to hear!
Sign In or Register to comment.