CrashReport: hard freeze/lock for a few seconds and then crash when switching weapons

MachoNatchoManMachoNatchoMan Posts: 4Member
edited July 24 in Crash Reports
got to the 2'nd or 3'rd jump on sector 2 i think, got through 2 groups of outlaw or okkar fighters and went to check on the loot. found a fusion blaster (+++) and then tried to switch it with my standard unupgraded gatling.. then the screen froze (no message about the game becoming unresponsive or grayed out screen that comes with said message) and crashed with this info.. not too sure what precisely i did but i essentially compared it with the gatling (it auto selected that slot) and then pressed my beam laser mk3 to compare, deciding i'd want to replace my gatling so i pressed on that again and i think i then pressed f on the keaboard to switch and then it crahsed)


---Extra---
really hope this can be fixed at some point sooner than later... just the chance of this happening at any random point is immensely frustrating and ruins the game for me :/ the whole point at least for me is the progress and collection of money to purchase upgrades and doing longer runs now to rack up the money is terribly worrying for me now as i could loose it all at any point for nothing what so ever :c

was introduced by vinny vinesauce a long while back from one of his vod's and recently picked it up to try and have turned out to really really like the game as a whole!! :) there really is not much bad at all that i can say about the game. wish you dev's the very best of luck with it and future endeavors and hope to see this game expand and flouring more so!! very hopefully with modding someday, even if it completely disables achievements at the least or makes you use a completely separate set of saves/progress. one for vanilla with achievements and one for modded. i know i would love that!!
---End of Extra---

LoginId:968bd51246b0a1a569d401964b0a34b1
EpicAccountId:c108233c26ce45fabc3c9e5ea09e604e

LowLevelFatalError [File:Unknown] [Line: 200] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - 'HUNG')

RSG_Win64_Shipping!FDebug::AssertFailed() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\core\private\misc\assertionmacros.cpp:425]
RSG_Win64_Shipping!TerminateOnDeviceRemoved() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:213]
RSG_Win64_Shipping!VerifyD3D11Result() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:249]
RSG_Win64_Shipping!FD3D11EventQuery::WaitForCompletion() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\windows\d3d11rhi\private\d3d11query.cpp:160]
RSG_Win64_Shipping!FD3D11DynamicRHI::RHIEndDrawingViewport() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:614]
RSG_Win64_Shipping!FRHICommandListExecutor::ExecuteInner() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rhi\private\rhicommandlist.cpp:573]
RSG_Win64_Shipping!FRHICommandList::EndDrawingViewport() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rhi\private\rhicommandlist.cpp:1509]
RSG_Win64_Shipping!FSlateRHIRenderer::DrawWindow_RenderThread() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:928]
RSG_Win64_Shipping!TGraphTask > >::ExecuteTask() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\core\public\async\taskgraphinterfaces.h:844]
RSG_Win64_Shipping!FNamedTaskThread::ProcessTasksUntilQuit() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\core\private\async\taskgraph.cpp:573]
RSG_Win64_Shipping!RenderingThreadMain() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rendercore\private\renderingthread.cpp:333]
RSG_Win64_Shipping!FRenderingThread::Run() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rendercore\private\renderingthread.cpp:467]
RSG_Win64_Shipping!FRunnableThreadWin::Run() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:76]

Edit: spelling correction

Comments

  • ROCKFISH_AndiROCKFISH_Andi Posts: 1,086Moderator
    Hi, thanks for the long report, but this is probably the Unreal engine crash that is most known and occurs most often, and as far as we know it's pretty random and can occur at any point. There are a few known measures that you can take to get rid of the problem or at least reduce the probability of it occuring:

    Editing the tdrdelay registry values can help, it also might help if you play at reduced graphics, tone down the overclocking of your graphics card, connect your notebook to a power source (if you're using one). You can find more details/suggestions in the following threads:

    https://answers.unrealengine.com/questions/670166/unreal-engine-is-exiting-due-to-d3d-device-being-l-8.html

    https://forums.funcom.com/t/unreal-engine-is-exiting-due-to-d3d-device-being-lost-error-0x887a0006-hung/9652

    https://www.reddit.com/r/playark/comments/7l2qcw/aberration_unreal_engine_is_exiting_due_to_d3d/
  • MachoNatchoManMachoNatchoMan Posts: 4Member
    no idea what to speciffically do with the tdrfelay values (used the registry a fair bit just not this in particular)

    reducing the graphics is something i really really really don't want to do as is. love the graphics of the game so far even though i find it somewhat slightly lacking on a 40' 4k monitor when zoomed in close to something (mostly othat than the players ship that is. the player ship is wonderfully done as far as i can tell) but long story short i am loving the game visually at max settings and therefore really really don't want ot loose any of that even if it means a more stable game :/

    will try toning down my gpu clocking as i have a overclocked card that is already overclocked in the factory :q had some serious issues with a coupple games in the past where they would not even run unless i toned down my gpu clock to -400 MHz

    and no i deffinetely don't use a notebook :p here are some specs in the attached image in case it helps.
    thanks again!


  • MachoNatchoManMachoNatchoMan Posts: 4Member
    edited July 25
    that's with the game on the main menu in the background btw.. i know the temps are kinda horrendus and i need a new cooling system for my cpu and not much can be done about the gpu sadly :| not that i know of anyway

    on idle with no games running my gpu is at around 53 C stable and cpu is only 1 C less on average
    Edit: actually now that it has cooled down a bit the gpu is stable around 41-42 C and cpu is stable around 55-56 C and spiking up to 59 or so when i do certain things
  • PedalToTheMetalPedalToTheMetal Posts: 136Member
    The temperatures on the above image are ok, it is 80 when you've got to at least start caring ;)
    About the TDR:
    https://docs.microsoft.com/en-us/windows-hardware/drivers/display/tdr-registry-keys
    No idea why they set it that low on Win10, changing delays to somewhat 10s should be fine.
  • MachoNatchoManMachoNatchoMan Posts: 4Member
    thanks will try it out sometime when i get around to the game again :) this issue kinda popped the bubble so to say :p still a great game though, at it's core in the very least. peace!
  • PedalToTheMetalPedalToTheMetal Posts: 136Member
    When done, could you post the result here? As I actually never had this error with any UE4 title (got TDR @ 8 seconds) it would be nice to have a direct proof of concept.
Sign In or Register to comment.