Game crushed after startup

Game started crashing after last update of NVIDIA GEFORCE driver
Now Vesion 418.81 from 02/04/2019 is used

Win10 X64, 16gb ram, gtx 1070 8gb, i7 7700

Crash report

Access violation - code c0000005 (first/second chance not available)

RSG_Win64_Shipping!FCachedBoundShaderStateLink::FCachedBoundShaderStateLink() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rhi\private\boundshaderstatecache.cpp:43]
RSG_Win64_Shipping!FD3D11BoundShaderState::FD3D11BoundShaderState() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\windows\d3d11rhi\private\d3d11shaders.cpp:224]
RSG_Win64_Shipping!FD3D11DynamicRHI::RHICreateBoundShaderState() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\windows\d3d11rhi\private\d3d11shaders.cpp:325]
RSG_Win64_Shipping!IRHICommandContext::RHISetGraphicsPipelineState() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rhi\public\rhicontext.h:338]
RSG_Win64_Shipping!FD3D11DynamicRHI::RHISetGraphicsPipelineState() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\windows\d3d11rhi\private\d3d11rhiprivate.h:481]
RSG_Win64_Shipping!FRHICommandListExecutor::ExecuteInner() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rhi\private\rhicommandlist.cpp:573]
RSG_Win64_Shipping!FRHICommandListBase::~FRHICommandListBase() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rhi\private\rhicommandlist.cpp:828]
RSG_Win64_Shipping!FRHICommandWaitForAndSubmitSubList::Execute() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rhi\private\rhicommandlist.cpp:1022]
RSG_Win64_Shipping!FRHICommand::ExecuteAndDestruct() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rhi\public\rhicommandlist.h:632]
RSG_Win64_Shipping!FRHICommandListExecutor::ExecuteInner() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rhi\private\rhicommandlist.cpp:573]
RSG_Win64_Shipping!FRHICommandList::EndScene() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rhi\private\rhicommandlist.cpp:1464]
RSG_Win64_Shipping!FDeferredShadingSceneRenderer::Render() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\renderer\private\deferredshadingrenderer.cpp:1417]
RSG_Win64_Shipping!RenderViewFamily_RenderThread() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\renderer\private\scenerendering.cpp:2854]
RSG_Win64_Shipping!TGraphTask<`FRendererModule::BeginRenderingViewFamily'::`20'::EURCMacro_FDrawSceneCommand>::ExecuteTask() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\core\public\async\taskgraphinterfaces.h:829]
RSG_Win64_Shipping!FNamedTaskThread::ProcessTasksUntilQuit() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\core\private\async\taskgraph.cpp:573]
RSG_Win64_Shipping!RenderingThreadMain() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rendercore\private\renderingthread.cpp:333]
RSG_Win64_Shipping!FRenderingThread::Run() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rendercore\private\renderingthread.cpp:467]
RSG_Win64_Shipping!FRunnableThreadWin::Run() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:76]


  • PedalToTheMetalPedalToTheMetal Member Posts: 149
    According to a quick search the 418.81 seems to be a little glitchy (both with UE4 and in general). As far as you don't have an RTX GPU I'd advice you to roll the driver back, probably even with a 3xx one.
  • cAndyMancAndyMan Member Posts: 20
    I use the gtx1060 6gb and have no problems with the latest driver (418.81) so far.
    If it is really a driver problem, I would suggest, too that you roll back to a later driver version and hope the next driver version will work better for you.
  • TorutisTorutis Member Posts: 2
    Unfortunatelly, rolling back to the old versions doesn't fix this problem
  • PedalToTheMetalPedalToTheMetal Member Posts: 149
    But did you really roll back? ;) I had an inverse issue though both may happen with an equal probability, that is uninstalling the newer driver still retains the driver cache (which is reused once Windows figures you've got a driver-less device), next the actual driver's installer tries to install the desired driver version but sees that a different one (the one it tried to kill off) is already there - with this, one simply installs the Control Panel as well as whatever other stuff it planned on while skipping the driver itself. Thus, re-check the version via Nvidia's Control Panel and see if it is actually the driver you were installing and not the initial 418.18. If it is the "wrong one", start digging from there (I had this on Win7, not 10, and actually sort of forgot how I killed the cache to get it done - but if not mistaken you can find some software that will do it for you - though myself I prefer the manual approach).
  • tyllelly23tyllelly23 Member Posts: 6
    Yeah yeah coming back to the older version can't help at all. I had to spend more than 1 hour on top1apk to find the way to roll back and nothing better happened as i expected.
  • PedalToTheMetalPedalToTheMetal Member Posts: 149
    edited March 2019

    I had to spend more than 1 hour on top1apk to find the way to roll back

    A shady Android app host is probably not the best place to look for a way of patching up your Windows drivers ;)

    p.s. @ OP: have you tried wiping off the shader cache (iirc UE holds it's own one, also the driver has it's cache too)? Also you can try disabling the cache in NVCP and see if it helps, though better not leave it off as it will cause a pretty much heavy CPU impact - yet it is a neat starting point.
Sign In or Register to comment.