Resolution reset on game start

CaveCave Posts: 3Member
edited January 2 in Bug Reports (ES1)
Hey there,

my monitors native resolution is 5120x1440.

After the games loading screen and the main menu appears the resolution falls back to 3840x1080.
Then I have to manually set the resolution back to 5120x1440. This needs to be done every time I start the game.

Is there a fix for this?

If you need more details like hardware components please let me know.

Comments

  • ROCKFISH_AndiROCKFISH_Andi Posts: 1,102Moderator
    Hi, it seems to me that for whatever reason, the resolution settings are not properly saved in the respective ini file as they should. But I've not heard of such a problem in a long time. And the last time something like this occured, we never found out why and were not able to help.

    I'm curious how your GameUserSettings.ini file looks like after changing the resolution. It is located at C:\Users\{YOUR_USERNAME}\AppData\Local\RSG\Saved\Config\WindowsNoEditor

    If you don't mind losing some settings like keybindings, etc. maybe you could try to delete the file and the game will create a default file the next time the game starts. The default should be windowed mode with 1920x1080 resolution. Now, if you go to the options and change the mode to fullscreen and the resolution to
    2540x1440, the following lines should be added to the ini file (most likely at the top, but it could be anywhere)

    ResolutionSizeX=2560
    ResolutionSizeY=1440
    LastUserConfirmedResolutionSizeX=2560
    LastUserConfirmedResolutionSizeY=1440
    FullscreenMode=0
    LastConfirmedFullscreenMode=0

    If I then close the game and start the next time, the game opens in full screen mode and applies the 2560x1440 resolution.

    So I'm wondering what happens in your ini file?
  • CaveCave Posts: 3Member
    edited January 3
    Hello Andi,

    my current GameUserSettings.ini looks like this:
    https://hastebin.com/buripazube.py

    I deleted this file and let the game recreate it. This is how it looks after starting the game, setting the proper resolution and fullscreen mode and closing the game: https://hastebin.com/uyaticogoy.py

    Then I restarted the game and the resolution felt back to 3840x1080 again. Without touching the configuration ingame and closing once again this is how the file looks like: https://hastebin.com/obapebiveb.py

    I hope this was useful for investigation.
  • PedalToTheMetalPedalToTheMetal Posts: 141Member
    Why not using the classic -ResX/-ResY switches? Yes, this is pretty stupid, but (a) it's gotta work, and (b) you don't switch your resolutions frequently enough anyway, do you? ;)
  • CaveCave Posts: 3Member
    edited January 4
    Because it is weird behavior which should not exist....well... I guess :p

    Edit: This is actually working though. I used the information I found here: https://steamcommunity.com/app/396750/discussions/0/152391995409984268/

    I added -FULLSCREEN ResX=5120 ResY=1440 as start options and it seems to work for now. Though I did not actually play, just started the game since I ran out of spare time.
  • ROCKFISH_AndiROCKFISH_Andi Posts: 1,102Moderator
    Hmm, thanks for the files, I don't understand why the 3840 resolution gets set, doesn't make any sense to me. I'm glad that you could manage to get it working with the -fullscreen launch parameter
  • PedalToTheMetalPedalToTheMetal Posts: 141Member
    Indeed this is somewhat weird, yet I'm afraid the reason may be hidden in the engine itself (as it does seem to properly restore any standard resolution).
    Anyway, just for the case you'd need other overrides like VSync and whatever:
    https://docs.unrealengine.com/en-US/Programming/Basics/CommandLineArguments
Sign In or Register to comment.