Losing Control of my ship - MacBook Pro Retina 13 Inch (Mid-2014)/ 10.13.6 (High Sierra) - Steam Ver

KTCAOPKTCAOP Posts: 2Member
Hello - I have lost four runs now to this and I am not sure what is causing the issue. The last run I had was such a good run for me but then the bug happened.

The issue is that every so often I lose control of the ship.

Keys that no longer work - WASD for movement, Tab, Escape.

Keys that do work - Left Control (to drop down) and Shift (to boost myself forward)

The first time this happened, I was stuck in perpetual motion as if my A key was stuck. I could smash all of the keys I wanted, but I could not control my ship. This was fullscreen before and I could not even CMD+TAB (change windows) and eventually my ship blew up.

This last time, I had full screen windowed. I suddenly was constantly being propeled forward. Because of full screen windowed I was able to get out of the window and test that my keys were indeed functioning. However, when tabbing back in, again, I could not control my ship.

Moving the mouse around, I did see the actual mouse cursor on the screen window as if there was some popup that maybe was interfering? But there was no error message on my desktop.

Possibly because of being full screen windowed, I was not able to move my mouse cursor around my desktop freely, and had to CMD OPT ESC and force quit the game. Unfortunately, force qutting the game ended my run instead of restarting me in the sector (which happened once when the game randomly crashed) and again, I lost a super good run.

I tried connecting a controller (XBOX 360 controller) into my mac and I still was not able to get control. I am using a bluetooth keyboard, however, even turning off the keybord and using the actual MacBook keyboard did not work.

I am using MacOS 10.13.6 - High Sierra on a MacBook Pro Retina 13-inch, Mid 2014.

Given my calculations, 80% of my runs have had no issues, I have made it to sector seven previously without any issues on some of my runs, but then I run into these types of runs and it is just utterly devestating and demoralizing to lose those kinds of runs.

Please advise if you have any suggestions as to what I could do - or if there is a way to quit the game to restart the sector. Thank you.

Comments

  • ROCKFISH_AndiROCKFISH_Andi Posts: 984Moderator
    I noticed you also wrote on the steam forums, I gave this reply there:

    Hi, sounds very weird, have not heard of such a problem before. I'll ask around here, if anyone has an idea what the problem could be. My first guess is either the game is losing focus for whatever reason (although it strange that there still are keys that are working) or that there is a conflict with maybe some gamepad you have connected. I'd recommend that you do the following: Unlplug all other input devices (maybe also controllers that are connected via bluetoooth etc.) and see if the problem is still there. If it is, maybe try playing in windowed mode and see if it occurst there as well.

    Other than that I'm surprised that your save game was lost when force quitting.
Sign In or Register to comment.