Crash on display options

kalocinkalocin Posts: 4Member
I'm at a bit of a loss here, the game keeps crashing when I go to the display options.

Operating system is Windows 10 with the game installed from the Microsoft Store. NVIDIA 980 TI with latest drivers installed. Microsoft account instead of local account.

Game version is v1.2.10.0 with encounters installed, if there is another version in the Microsoft Store, it won't update more than here. The game iwill crash at display options with or without encounters installed.

I cannot access any configuration files because I am using it through the Microsoft Store, there is no RSG file in the hidden local apps folder.

The game itself is able to load but it's stuck in windowed mode and I can't adjust any graphic settings. The game isn't recognized by Nvidia Geforce Experience so I can't adjust it through there either.

I have restarted my computer with multiple uninstalls/reinstalls between.

I'm really not sure where to go from here honestly.

Comments

  • kalocinkalocin Posts: 4Member
    I found the graphic settings file under AppData>Local>Packages and can adjust some of the settings there, but the game won't switch to fullscreen when I adjust it, and it still crashes on the display menu.
  • ROCKFISH_HCKROCKFISH_HCK Posts: 556Moderator
    Hi! There is no exclusive fullscreen modus in the Windows Store version because it builds on UWP. So no need to change from windowed mode. Have you tried to lower your graphics settings in the GameUserSettings.ini? Try setting the quality values to 0 or 1 (GraphicsQuality, EffectsQuality, etc.) and see if you could at least enter the display options menu again.
  • kalocinkalocin Posts: 4Member
    edited August 8
    Adjusting the settings from 0-3 still results in a crash (as well as trying to set things to true/false such as desired resolution which doesn't seem to work). I'm not sure if it matters or not but the only ini files with information in them are GameUserSettings and Input. I'm pretty certain the game isn't being affected though after changing things to really wonky numbers (ie mouse speed to 1000). I've tried disconnecting the Xbox Live account, it says it won't save the game and to press any button but the game just locks with that text. I can get into the WindowsApps folder by changing the security, not much Windows will let me do in the game's app folder though.

    In the other folder is crash reports that read out this:
    [CrashReportClient]
    bHideLogFilesOption=false
    bIsAllowedToCloseWithoutSending=true
    CrashConfigPurgeDays=2

    (I did try changing the true to false but it just made another folder with the same thing)

    Not sure what else I can try to adjust.

    Edit: For the sake of sanity I also did a full clean Nvidia driver reinstall again but alas there is no change. I also updated my Motherboard's BIOS because why not, still no change.
  • rfg_joernrfg_joern Posts: 7Moderator
    Hi kalocin,
    when reinstalling the game have you also tried to (backup and) delete the ROCKFISHGames.* folders in AppData/Local/Packages to ensure the new installation also comes with a clean config? Your save games are stored via XBox Live and should not be affected by this step. Also I would recommend to watch out for any third party tools that might interfere with some graphics buffers (e.g. Fraps) and disable them.
    From my experience it is not advisable and rather pointless to mess with UWP folders access rights. Usually Windows will just 'fix' them automatically but probably there's still a chance to seriously break things.
  • kalocinkalocin Posts: 4Member
    I've deleted every file potentially related to the game (delivery optimization files too), and I don't currently have any overlays (Nvidia one is disabled, gamebar/mode is disabled too). I installed the game on my laptop which managed to work with the display options, seems like it just really hates my desktop.
Sign In or Register to comment.