another crash - mid battle this time

BadDogBadDog Posts: 7Member
Game version v1.3.0.36069
Win10 64bit , i5-4590, 8gb ram, gtx660, nvidia driver 398.36


LoginId:3f8bc3d84c5f506d398af2848fb2de23
EpicAccountId:

LowLevelFatalError [File:I:\Intermediate\RSG_Configurable_Win\Engine\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 1015] GameThread timed out waiting for RenderThread after 30.00 secs

RSG_Win64_Shipping!FDebug::AssertFailed() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\core\private\misc\assertionmacros.cpp:414]
RSG_Win64_Shipping!GameThreadWaitForTask() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\rendercore\private\renderingthread.cpp:1021]
RSG_Win64_Shipping!FEngineLoop::Tick() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\launch\private\launchengineloop.cpp:3448]
RSG_Win64_Shipping!GuardedMain() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\launch\private\launch.cpp:166]
RSG_Win64_Shipping!GuardedMainWrapper() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\launch\private\windows\launchwindows.cpp:134]
RSG_Win64_Shipping!WinMain() [i:\intermediate\rsg_configurable_win\engine\engine\source\runtime\launch\private\windows\launchwindows.cpp:210]
RSG_Win64_Shipping!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:253]
kernel32
ntdll

Comments

  • ROCKFISH_AndiROCKFISH_Andi Posts: 1,086Moderator
    This seems to be a different message/error than the other ones you posted, this seems to be an error that other Unreal engine games are getting as well (even fortnite). There are a few suggestions how to fix this for you in this lenghty thread on the PUBG steam forums: https://steamcommunity.com/app/578080/discussions/1/1621724915775027967/?ctp=4
  • PedalToTheMetalPedalToTheMetal Posts: 136Member
    Just for you to know. I have a pretty much alike system yet with a factory-overclocked card and 4570. I don't play much yet with both the new Unreal Tournament and Everspace I never had a single crash. Win7 x64 and I usually set games to run in a fullscreen window mode (not because of the crashes but just for the faster switching). Used both the 362.00 GPU driver (kinda hated how it deals with watchdog and depth buffers but that's just me) and 398.11 (warp tricks in compute shaders no longer work, just be warned). So, looks like an OS-specific bug, try running in window first as W10 seems to have some "fullscreen optimizations", which can be the cause as people stated.
  • BadDogBadDog Posts: 7Member
    edited July 2018
    Well I checked out these posts and I installed EVGA Precision X OC (my card is EVGA GTX660 SC version, which I just run stock up to now), dialling down the clocks did nothing, but dialling down the power target (voltage) to 90% seems to have made a difference, no crashes so far.......its early days though.

    I was running in windowed mode, ill try full screen window next, thanks for the idea.
  • PedalToTheMetalPedalToTheMetal Posts: 136Member
    In fact windowed and "full-screen" windowed modes are basically the very same with the only difference being the window border style - which is definitely the last thing to cause any crashes.
    As for the voltages, I guess the result is simply clamping the clock rates at a lower value which creates less clock drift. Better check using GPU-Z or something. If the clock drift is the cause, just set everything back to defaults and set "Prefer maximum performance" in NVIDIA CP which will remove the clock control altogether (simple as that, it will just clock up to the max frequency whenever you start ES and never drop it even should a lower clock rate be enough to maintain your swap rate).
  • BadDogBadDog Posts: 7Member
    more crashes today one of each type......don't know what to do now
  • BadDogBadDog Posts: 7Member
    well i don't know if this is windows, or unreal engine but had enough now another 3 crashes, and I even tried adjusting the windows setting to disable full screen optimisations.
    So I'm disabling precision XOC and trying the nvidia , Use my preference emphasising : performance.
    But I've had enough now, good game when it works.......
  • PedalToTheMetalPedalToTheMetal Posts: 136Member
    Well, unless it is OS-specific (you could later - and probably should - try to dual-boot into Win7 just as there can be issues with W10 just like with every fresh OS) I guess I know the biggest difference our systems may probably have which can be the cause!
    By default, every Intel system allows to use both the integrated and the PCI-E GPU at once. As I didn't really care of the extra wattage (and there is not much of it anyway as my GPU idles at 324/162 MHz core/mem respectively), extra monitors and never wanted any extra mess I simply disabled the integrated GPU via BIOS so that my system now runs on the PCI-E GPU alone. Try doing the same, it isn't any difficult anyway and seems to solve the problem for some (I never tried the dual-GPU setup however so can't tell if it causes any problems).
  • BadDogBadDog Posts: 7Member
    Update, I got hold of an asus gtx 1050ti advanced 4gb to try, and so far 3 days and no crashes, so I am wondering is there a problem with the gtx 660, or given that the 1050ti uses mobo power and not a direct feed from psu could it be my psu? thats an antec 520w HCG, I don't overclock anything so that should have been plenty of power and it met the spec required by evga for the 660.
  • PedalToTheMetalPedalToTheMetal Posts: 136Member
    Unless an unlucky OS/driver combination, no, GTX660, like I already said, has no problems with neither Everspace nor any other UE4 projects. Overclocking is not an issue as I run a factory-overclocked GPU of the named type without disabling the overclock of course.
    For the PSU, better check if the caps have failed (if too lazy to open it up, try checking the outputs with an oscilloscope - yet do never consider any shady "soundcard scope" software, only use a real scope).
    In fact, normally an ATX PSU can not cause any major voltage drops on an individual bus as all the buses are tied via the transformer's winding coupling with only the 3.3v bus being used for feedback. Thus should you overload any bus, it will either cause a voltage drop on all the buses at once (excluding 5v standby which isn't really useful during runtime anyway) and causing a massive system crash, or (more likely) trip the PSU's OCD, shutting it off, - or (had it long ago) a cheap/worn out PSU can enter a state where the OCD doesn't trigger yet the halfbridge switches start to heat up uncontrollably. The latter, of course, is the PSU's instant demise.
Sign In or Register to comment.