Forum bugs/issues

ES_1976ES_1976 Posts: 2Kickstarter Backer, Space Cat
Hi there (or Moin).
I know the forums are quite fresh and unpolished, but I would like to point out some minor bugs/issues I encountered so you can eventually fix them:
- Add a correct HTTPS certificate for the forums. I am not comfortable to use plain http when logging in, so please add a valid certificate in the near future.
- Please check the forums with Firefox, as I see quite some icons not showing up properly. They appear like Unicode placeholders to me. I find them in the following places:
-- the links at the top, right hand side of my user name.
-- If i click on my username, right before "preferences" in the middle panel and left of "activity", "notifications", "discussions", "comments" and "inbox" on the right panel.
«1

Comments

  • deathcatdeathcat Posts: 4Kickstarter Beta Backer, Space Dog
    I'm using the latest Firefox, and those icons look fine to me. Perhaps local settings on your browser?

    I agree with HTTPS as well.
  • ValXpValXp Posts: 2Kickstarter Alpha Backer, Space Optimizr
    HTTPS is a _must_ have especially for login.
  • DavidDavid Posts: 31Kickstarter Alpha Backer, Space Pro
    edited January 2016
    When in the Forum, allow the red 'Forum' link in the Navigation at the top to link to the Forum Home page. I keep trying to use it to return to the home but can't :(

    Have a Forum FAQ as well as an FAQ for the game.

    Edited to add: I noticed in the discussions there is an 'new' posts/replies icon, I think this is useful, but I think a counter would be more useful, I think this would also be good to have on the Categories page as well.

    Edit no 2 to add: the 'like' link in posts isn't displaying (in Firefox on a mac) unless the post is hovered over by the mouse.
  • RaptorAlphaRaptorAlpha Posts: 67Kickstarter Alpha Backer, Space Pro
    The "Like" link is that way for Win10/Chrome too.
  • ROCKFISH_SnoopROCKFISH_Snoop Posts: 92Moderator
    ES_1976 said:

    Hi there (or Moin).
    I know the forums are quite fresh and unpolished, but I would like to point out some minor bugs/issues I encountered so you can eventually fix them:
    - Add a correct HTTPS certificate for the forums. I am not comfortable to use plain http when logging in, so please add a valid certificate in the near future.
    - Please check the forums with Firefox, as I see quite some icons not showing up properly. They appear like Unicode placeholders to me. I find them in the following places:
    -- the links at the top, right hand side of my user name.
    -- If i click on my username, right before "preferences" in the middle panel and left of "activity", "notifications", "discussions", "comments" and "inbox" on the right panel.

    I'll let the team know! Thank you for the feedback.
  • KoshKosh Posts: 2Kickstarter Alpha Backer, Space Booster
    Adding another call for a proper (NOT self-signed) SSL certificate. I'm actually surprised that the forums went live without it.

    Also agreeing with the request to allow the "Forums" link in the navigation bar to bring you back up to the root level of the forum structure, from whatever sub forum (Gameworld/Community/Off Topic/etc) you are in.
  • SaloriusSalorius Posts: 32Kickstarter Alpha Backer, Space God
    On my browser the "quotes" are in quite big letters, larger (about double) than the original letter size of the posts....
    Should be just reverse, make the size of the quotes half in height compared to the comments/posts.
  • Templar3lfTemplar3lf Posts: 54Kickstarter Beta Backer, Space Dog
    David said:

    When in the Forum, allow the red 'Forum' link in the Navigation at the top to link to the Forum Home page. I keep trying to use it to return to the home but can't :(

    This would be really helpful. At the moment the link is just disabled while you are anywhere on the forum.
  • 3L733L73 Posts: 7Kickstarter Alpha Backer, Space Optimizr
    Moin Moin.

    As far as I can see on style sheet file is missing.

    I can confirm that the icons are not shown under Firefox/Windows.
    It seems that the font file is not loaded.

    The use of emotion is not working when using the smartphone. An image is attached.

    Regards

    Elte
  • Templar3lfTemplar3lf Posts: 54Kickstarter Beta Backer, Space Dog
    edited January 2016
    Oh also, the star, top right of a thread, which claims it will bookmark things on the hover-text, does not seem to do anything. Maybe this is a lack of button feedback, or maybe it genuinely does nothing?

    Edit: Ok, apparently it does do something. Maybe it should be edited so that it stays the same blue as it goes when hovered over, while bookmarked, so that you know if the thread is bookmarked or not.
  • TatsukishiTatsukishi Posts: 20Kickstarter Alpha Backer, Space Optimizr
    Hey, the title of the forum home page (forum.everspace-game.com) just reads "FORUM" as title, with no mention of Everspace.
  • WoonaWoona Posts: 22Kickstarter Alpha Backer, Space Optimizr
    My only complaint so far is that once you've switch to desktop view there is no way to switch back to mobile view. It's not a huge problem, but both have uses and I'd like to have the functionality of desktop and then switch to the form factor of mobile without having to sign out and close the page :P
  • ROCKFISH_SnoopROCKFISH_Snoop Posts: 92Moderator
    Just to keep you guys up to date, we are actively monitoring the forum bugs and issues and squishing them as fast as possible. This week we should have proper SSL in place, as well as a number of other fixes. Stay tuned for now.
  • DavidDavid Posts: 31Kickstarter Alpha Backer, Space Pro

    Just to keep you guys up to date, we are actively monitoring the forum bugs and issues and squishing them as fast as possible. This week we should have proper SSL in place, as well as a number of other fixes. Stay tuned for now.

    Good to know, we definitely appreciate the official feedback.
  • Templar3lfTemplar3lf Posts: 54Kickstarter Beta Backer, Space Dog
    Another niggling problem I have noted is that profile pages do not update properly when accessed. At the time of writing I have 33[+1] forum posts, and have logged in countless times, and yet my profile only shows to me that I have 25 forum posts, have logged in only once, and that was yesterday.
  • d3rr1nautd3rr1naut Posts: 22Kickstarter Alpha Backer, Space Rogue
    David said:

    When in the Forum, allow the red 'Forum' link in the Navigation at the top to link to the Forum Home page. I keep trying to use it to return to the home but can't :(

    I was looking for a post on this forum that would suggest this. Please implement this. I'm so used to navigating a site by clicking on buttons like these.
  • Kurzon MorrisKurzon Morris Posts: 73Kickstarter Backer, Space Cat
    the thing I want is the ability to edit top lvl threads after the 1 hour. I'm doing a couple of posts that do regular updates and really could use the ability to actually update the primary post. please..

    pretty please????
  • Kurzon MorrisKurzon Morris Posts: 73Kickstarter Backer, Space Cat
    may seem a tiny thing but on the steam version can we get cloud support? means i can play on my tablet and then carry on, on my main pc
  • d3rr1nautd3rr1naut Posts: 22Kickstarter Alpha Backer, Space Rogue

    Oh also, the star, top right of a thread, which claims it will bookmark things on the hover-text, does not seem to do anything. Maybe this is a lack of button feedback, or maybe it genuinely does nothing?

    Edit: Ok, apparently it does do something. Maybe it should be edited so that it stays the same blue as it goes when hovered over, while bookmarked, so that you know if the thread is bookmarked or not.

    confirmed. Have the same issue. Using Chrome.
  • WeatherstationWeatherstation Posts: 42Kickstarter Alpha Backer, Space Pro
    @Kurzon Morris isn't the cloud support available on every steam game?
  • Templar3lfTemplar3lf Posts: 54Kickstarter Beta Backer, Space Dog
    There seems to be a Steam category with cloud support, or at least a tag, suggesting that this is not the case @Weatherstation, but I may be wrong.
  • Templar3lfTemplar3lf Posts: 54Kickstarter Beta Backer, Space Dog
    Another issue seems to be, on the latest Desktop Chrome when editing a post, the quick HTML buttons (Weblink, formatting, etc) don't seem to work. I cannot test on another browser at this time.
  • Kurzon MorrisKurzon Morris Posts: 73Kickstarter Backer, Space Cat

    @Kurzon Morris isn't the cloud support available on every steam game?

    nope and yup. Its available to all developers and games but not every game supports it for saves. If you go to the page of a game and look at the list of important features like singleplayer and controller support etc... on many games, Including Galaxy on fire 2 HD there is no mention of supporting the cloud save. So really hope they impliment it
  • ROCKFISH_SnoopROCKFISH_Snoop Posts: 92Moderator

    may seem a tiny thing but on the steam version can we get cloud support? means i can play on my tablet and then carry on, on my main pc

    I'll look into it ;)
  • WeatherstationWeatherstation Posts: 42Kickstarter Alpha Backer, Space Pro
    Also is it normal that there is a "reported post" section? ... maybe it would be better to hide it ;)
  • Templar3lfTemplar3lf Posts: 54Kickstarter Beta Backer, Space Dog
    @Weatherstation that seems to have been mentioned some time ago, or at least I remember it being mentioned, and I swear it was fixed then. Maybe they just removed it from the quicklinks bar on the right.
  • WeatherstationWeatherstation Posts: 42Kickstarter Alpha Backer, Space Pro

    @Weatherstation that seems to have been mentioned some time ago, or at least I remember it being mentioned, and I swear it was fixed then. Maybe they just removed it from the quicklinks bar on the right.

    Actually it is still on the quicklinks bar ^^
  • WeatherstationWeatherstation Posts: 42Kickstarter Alpha Backer, Space Pro
    It would be nice, if I could see when someone quotes one of my posts .... I can only see if someone mentions me with @Weatherstation ...
  • 3L733L73 Posts: 7Kickstarter Alpha Backer, Space Optimizr
    Morning everyone.

    Got a problem with quoting comments today.

    When clicking on the quote link, the word "null" is inserted instead of the quoted comment.
    Looks like a problem with JavaScript.

    Browser: Safari/WebKit
    Context: Mobile view
  • SaloriusSalorius Posts: 32Kickstarter Alpha Backer, Space God
    There could be much more living traffic on the site, if we could use our OWN self generated names for the login procedure, rather than this awkward "ES_1234567" login name.
    This is, because when I am out of home and stay idle at the hotel, airport etc., my OWN forum name I do always remember, but this intergalactical SSN "ES_121212" I never remember.
    Thus I just quit logging in..... too annoying....

    This is almost the only forum I have encountered, where a user has to handle all these multiple names for just one account.... :#
Sign In or Register to comment.