Everspace Encounters Won't Launch (Mac OS X, GOG)

I purchased Everspace for OS X from GOG.com. It's been running fine--until I bought and tried to install Everspace Encounters using GOG Galaxy. Now it gets to the full-window "Everspace" load screen and crashes back to the Finder at the end. When I log into OS X using a clean, test account, the game launches fine. This makes me think something in a config file was messed up by GOG. I found and deleted the files in /Library/Application Support/Epic/Unreal Engine/4.16, but that didn't seem to do anything. Welcome any other thoughts. The folks at GOG don't have any ideas and referred me to you.

(Also, if I install an older version of the game, say 1.1.3, that seems to work on my main account--but of course then I can't launch Encounters!)

I see there are crash logs in /Library/Application Support/Epic/Unreal Engine/4.16 and attached a Zip of them.

OS X is High Sierra 10.13.3. Everspace version is 1.2.234636. My full ticket to GOG and their response is below.

Many thanks for your help.


GOG.com ticket:

I have Everspace 1.2.234636 installed for Mac. It was installed from the standalone installer and was working fine. I purchased Everspace Encounters, and, not seeing a standalone download, tried to install it using GOG Galaxy. GOG Galaxy then reinstalled the main Everspace application and tried (I think) to install Encounters, but now the game won't run--it gets to the "Everspace" loading screen and then crashes back to Finder.

I used GOG Galaxy to uninstall the app and then reinstalled from the standalone installer, but I get the same problem. I also logged into OS X using a test account, and Everspace launched fine. This makes me think one of the hidden preference files may have been corrupted. Where can I find those files so I can try deleting them? I don't want to delete my save games, just anything else that might be causing the problem.


Hello

I've searched for the location of the configuration files, but was unable to locate them.
I can only suggest contacting the official support for the game. They should know where these files are.
[email protected]
I apologize for the inconvenience.
Regards
Genoan
GOG.com Support

Comments

  • ROCKFISH_AndiROCKFISH_Andi Posts: 1,033Moderator
    Hi, sorry for getting back so late - this one must have slipped through.

    The config files location on Mac is /Library/Preferences/RSG/MacNoEditor.

    I suggest you delete this directory, and completely remove Everspace from disk (maybe make a backup copy of your save games located at /Library/Application Support/Epic/RSG/Saved/SaveGames) and then re-install the latest version (which should be 1.3.0.XXXXX now).

    Hope that helps!
Sign In or Register to comment.