Cant Turn off Auto Roll Function? (bug?)

Duin55Duin55 Posts: 2Member
Hi,

I picked up on everspace again after a long time and I have 1 problem with it. After a couple of rounds: Auto-roll turns on(even thought the menu says it doesnt) and I cant turn it off no matter what I try. The only thing that works is uninstalling and installing again (for a couple of rounds).

Is there something I am doing wrong or is this a bug?

I play on Windows 10 via Steam. I have the DLC and the version of the game is: v1.2.2.2.34636

Thanks in advance,

Kind regards,
Thom

Comments

  • ROCKFISH_AndiROCKFISH_Andi Posts: 984Moderator
    Hmm, sounds weird - not sure how this could possibly happen. Are you sure that it's definitely auto-roll (so it stops when your ship is "level") - or could it be that the game constantly receives roll input?

    In any case, if you currently have the problem (or next tim you have the problem), please find the following files

    - C:\Users\{YOUR_USERNAME}\AppData\Local\RSG\Saved\SaveGames\CurrentPlayerSave.sav
    - C:\Users\{YOUR_USERNAME}\AppData\Local\RSG\Saved\Config\WindowsNoEditor\Input.ini
    - C:\Users\{YOUR_USERNAME}\AppData\Local\RSG\Saved\Config\WindowsNoEditor\GameUserSettings.ini

    and zip and attach them here and we'll see if we can reproduce and analyze the problem.


    After having attached the files you could also try if deleting the Input.ini and GameUserSettings.ini (this will reset all controls bindings) will fix the problem for you.

  • Duin55Duin55 Posts: 2Member
    Will do!

    Thank you
  • diggiharrydiggiharry Posts: 2Member
    Hi,

    I've exactly the same problem, but I'm running linux:
    Inside the game, auto-roll is always activated, independent of what is set in the options.
    Deleting the save games resolves the issue, but of course removes all the progress I made.
    Deleting the config files doesn't help.
    Reinstalling also does not help.

    I've attached the files mentioned in the post above, hopefully that will help.

    cheers
    Simon
  • ROCKFISH_AndiROCKFISH_Andi Posts: 984Moderator

    Hi,

    I've exactly the same problem, but I'm running linux:
    Inside the game, auto-roll is always activated, independent of what is set in the options.
    Deleting the save games resolves the issue, but of course removes all the progress I made.
    Deleting the config files doesn't help.
    Reinstalling also does not help.

    I've attached the files mentioned in the post above, hopefully that will help.

    cheers
    Simon

    Hi, I just had a look at your problem. As far as I can tell there's nothing wrong with autoroll, but your ship seems to roll instead of to yaw. So I guess that this is actually the problem you were talking about? It seems that you once somehow had a key assigned to the "switch roll and yaw" action. This action is something we added for players who like to switch on the fly if they'd like to roll or yaw with theit joystick. With the most recent state being saved in the save game.

    So in order to fix this, please try the following: Open the customize controls menu and assign a key that is not used (e.g. "k") to the action "switch roll and yaw" in the mouse & keyboard column.

    Then press this key once while in the game. You should then be able to normally yaw. If it works you shoudl then best go back to the customize controls menu and delete the binding, so you don't hit the button accidentally anymore.

    Hope that helps!
  • diggiharrydiggiharry Posts: 2Member
    Hi !

    Yes that did indeed help !
    I Also found out what happened, if I press the mouse button behind my scrolling wheel, the game will go into the menu, switch the camera and switch roll and yaw, so I guess that is what happened to me earlier and I didn't realise.
    Thank you very much!
Sign In or Register to comment.