Plugin 'OnlineSubsystemSteam' failed to load

This discussion was created from comments split from: My game won't start - what can I do?.

Comments

  • PolymerosPolymeros Posts: 11Customer
    Hello,

    I have the GOG version and no steam installed on my computer. When I try to run the game, I get this error message.



    I have already gone through the list in the first post.

    I would appreciate any insights.
    Thanks
  • PolymerosPolymeros Posts: 11Customer
    Wow... A week and no response whatsoever. Not impressed with the support by Rockfish.

    This is a game we purchased to play, not to do troubleshooting and beta testing for you.
  • GiraffasaurGiraffasaur Posts: 1,098Moderator, Space Cat
    Polymeros said:

    Wow... A week and no response whatsoever. Not impressed with the support by Rockfish.

    This is a game we purchased to play, not to do troubleshooting and beta testing for you.

    Sincere apologies; the team manages from a wide range of mediums and sometimes (though rarely) some troubleshooting requests are missed.

    This looks like an issue with Unreal, not GOG specifically. Let's see if @ROCKFISH_Andi or @ROCKFISH_Sven see if they have a solution.
  • PolymerosPolymeros Posts: 11Customer
    It looks like Unreal uses a plugin from Steam and as I have not steam installed (I don't like it, that is why I chose to purchase the GOG version), the game does not run.
  • ROCKFISH_HCKROCKFISH_HCK Posts: 562Moderator
    Sorry for replying so late. We will have a look at what is going on there and come back to you as soon as possible.
  • ROCKFISH_SvenROCKFISH_Sven Posts: 93Moderator
    edited June 2017
    Hi @Polymeros,
    unfortunately we were not able to reproduce your problem.
    Could you create a new thread(!), copy the initial problem and tell us:
    • Which Windows version are you using and if it is 32 or 64 bit.
    • Does the problem persist if you start the game with parameter “-nohmd”
      1. Create a shortcut to [Install Dir]\Everspace\RSG\Binaries\Win64\RSG-Win64-Shipping.exe by draging and dropping the .exe file with the right mouse button
      2. Rightclick => Properties
      3. Add a space and then -nohmd at the end of the “target” field
      4. Start that Shortcut
    • Do you or did you have any kind of VR hardware attached to your PC?
    • Please tell us how you installed the game (via GOG Galaxy client or via downloaded Install file).
    • Which game version do you have (Have a look in the Client or the install file name)?
  • PolymerosPolymeros Posts: 11Customer
    Hello @ROCKFISH_Sven

    I do not understand why a new thread is needed, as the problem is exactly that the game will not start. I believe all possible reasons and instances should be in the same thread where people can find them in one place. If I started a new thread, it would still be called "My game will not start", which would be confusing and kind of silly.

    On your questions:

    1. Microsoft Windows 10 Pro [Version 10.0.15063] x64
    2. The problem persists when I run it with the shortcut and parameter you described. It gives the exact same message. Once, it also crashed after displaying the same message. I have CrashContext.runtime-xml and UE4Minidump.dmp available to send to you if needed.
    3. I never had any VR hardware.
    4. I installed the game via downloaded install file.
    5. I have version 1.0.8.32661 (12776) but it did the same with the previous version 1.0.7 (I don't recall the rest, I deleted the file after I installed the new version).

    I believe it may be helpful to check if your current version requires Steam to be installed, as it is not in my computer.

    Many thanks.
  • ROCKFISH_SvenROCKFISH_Sven Posts: 93Moderator
    edited June 2017
    Hi @Polymeros,
    I created a new thread for this issue now. Please understand, that it gets hard to track, which threads still needs attention by us, when several different issues are discussed in one thread and it gets horribly confusing once several issues are discussed at the same time in the same thread. Although the outcome might be the same (game doesn’t start) you have a (until now) very unique error message, so we would like to treat this as a separate issue. If it turns out, that this issue needs a client side action and is relevant to several users, then I will add the solution to the “Game won’t start” front post. If it turns out we have to fix the issue on our side, we will just do that and users with other issues won’t have to read through all these post, which are not relevant to them. We do try to keep this as unconfusing as possible.

    Back to the actual topic:
    Thank you for the info about your Windows version! All our tests regarding this issue were done on a PC with no Steam client installed, but we will repeat the test with a setup more close to your Windows version and with install files.
  • PolymerosPolymeros Posts: 11Customer
    Thank you. I will be waiting for your recommendations.
  • ROCKFISH_SvenROCKFISH_Sven Posts: 93Moderator
    edited June 2017
    Hi @Polymeros,
    We did some more tests with a setup like yours, but unfortunately we still can’t reproduce the issue. We made some changes for the next patch, which might fix this problem, but because we can’t reproduce it, we can’t be sure.

    We have another question for you: Where you ever able to play or did this issue occur right from the very first start?

    And there is another thing we would like you to try:
    Could you reset your Config folder (if it exists)?
    1. Quit your game / close the error message (VERY IMPORTANT)
    2. Windows Key + R => enter %localappdata% =>Open "RSG\Saved" => Rename "Config" into "ConfigOld"
    3. Try to start the game again
  • PolymerosPolymeros Posts: 11Customer
    Hello,

    I was able to play all versions that I tried before 1.x.x. I then stopped following the game for some time as I was very busy and then picked up again now, when the game was at 1.0.7. but was never able to run it.

    %localappdata% will not get me to the appdata\local folder within my profile. It may relevant to the latest version of windows 10 that I am running. But I did go to C:\Users\---MY-PROFILE---\AppData\Local and followed your procedure. When I tried to run the game it created a new config folder but game the same error message.

    When do you think the patch will out?
  • PolymerosPolymeros Posts: 11Customer
  • PolymerosPolymeros Posts: 11Customer
    That emoticon was meant to read D : drive (if you put D and : next to each other, you get the emoticon).
  • ROCKFISH_SvenROCKFISH_Sven Posts: 93Moderator
    edited July 2017
    >%localappdata% will not get me to the appdata\local folder within my profile.
    What happened instead? This should work for all Windows versions since Windows 7 and definitely for all Windows 10 versions.

    >Similar situations with UE4
    We are using a prebuild Engine for Windows, we do not compile the Engine (for Windows) at all and our build server does a full rebuild of the game every time, so the problem you linked should not apply here.

    >Could it have something to do with the fact that the game is installed on D Drive
    The game usually works regardless of the installation folder. Only dependency I could think of would be if there is some kind of permission restrictions on a specific drive or folder.

    >When do you think the patch will out?
    I don't have an estimation about that.
  • PolymerosPolymeros Posts: 11Customer
    when I do run --> %localappdata% I get the windows 10 "How do you want to open this file" dialogue...

    Thanks for all the answers.

    Any other ideas I may try to run the game?
  • PolymerosPolymeros Posts: 11Customer
    I just fixed issue with %localappdata% not working. There was a file in C:\users with my user name as its name. I deleted it and now typing %localappdata% or %appadata% in run works as it should.
  • PolymerosPolymeros Posts: 11Customer
    I found the solution to the problem at this link: https://answers.unrealengine.com/questions/501921/413-plugin-onlinesubsystem-failed-to-load-on-engin.html

    I uninstalled the game, deleted the installation folder with whatever was left in it and then installed the game by right clicking on setup and selecting run as an administrator.

    The game is working now.
Sign In or Register to comment.