[BUG?] Weaponfire Doesn't Track Crosshairs

Mr. MagniloquentMr. Magniloquent Posts: 20Member
I recently and eagerly upgraded to the full release version (GoG 1.0.6.32482). I came to immediately notice that weapon fire no longer articulates based on cursor position. Rather, weapons now shoot straight ahead rigidly in plane with the ship irrespective of where my cursor is. Furthermore, if I lock the cursor on center, my mouse is no longer capable is steering the ship.

I'm not sure if this is a feature, or a bug. I'm going to bet it's a bug though.

Comments

  • ROCKFISH_AndiROCKFISH_Andi Posts: 1,086Moderator
    Sounds like a bug - but it's the first time we're hearing this.. really strange. But the ship steers alright with the mouse? it's just the firing?
  • Mr. MagniloquentMr. Magniloquent Posts: 20Member
    edited May 2017
    The ship steers fine so long as my cursor isn't fixed on the center per the options menu.

    I experimented some more, so maybe I can better explain now. When firing a weapon, only the initial burst tracks my cursor. Everything after that stays fixed to the original location that I clicked so long as I hold the fire button. For example, if I were to aim in the right of my screen, hold the fire button, then fly towards the left of my screen, my weapons would still be shooting towards the right.

    The only thing that causes my fire to change direction when sustaining fire is the literal orientation of the ship. The moment I release the fire button, and begin a new shot, the projectiles will recenter on my aiming reticule. I don't have any game recording software, though if you're totally vexed, I will consider trying to make one.
  • Mil-SpecMil-Spec Posts: 5Member
    I get the exact same thing. I tried to record using both Fraps and the windows 10 recorder/game bar, but it looks like they won't work for me in only Everspace (even a screenshot while in game only shows the black screen with "Everspace" logo, and Rockfish Games).

    Just a tad of a lowbrow workaround is to repeatedly press the fire button so that the firing position changes, but it makes the gatling useless, because that takes a while to spin up (It'd be great if you could start out with the shotgun IMHO).

    It'd be a better game if it worked correctly.

    Looks like there was someone else having the issue...
    https://steamcommunity.com/app/396750/discussions/1/343787283745405011/
  • Mil-SpecMil-Spec Posts: 5Member
    P.S. The ship does steer fine with the mouse movement, but the weapons are locked on the position that your mouse/cross-hair was originally on when you start firing.
  • ROCKFISH_AndiROCKFISH_Andi Posts: 1,086Moderator
    Could you guys test if there is a difference when you have the controls options "use sysem mouse position" checked or unchecked?
  • Mil-SpecMil-Spec Posts: 5Member
    If I have "Use system mouse position" unchecked, the crosshair is then centered and stops responding entirely to mouse movement (as does the ship itself). The only way mine works (change crosshair position and ship steering) is with "Use system mouse position" checked.
  • Mil-SpecMil-Spec Posts: 5Member
    Side Note: For me it gives the exact same result as checking the Center crosshair option.
  • Mil-SpecMil-Spec Posts: 5Member
    Update: I'm not sure if it was the last patch, or restarting the game, but mine is working correctly now.
Sign In or Register to comment.