next/previous weapon refuse to rebind from scroll wheel [PC]

OneSpeedOneSpeed Posts: 4Member
When rebinding the "next weapon" or "previous weapon" command to a non default key the game insists on keeping them also bound to the defaults (mouse scroll up/down), even if you've also assigned the scroll wheel to another task.

(also you cannot submit a discussion to this forum if you're using mozilla firefox, as the button does not appear)

Comments

  • ROCKFISH_HCKROCKFISH_HCK Posts: 562Moderator
    OK, thanks for reporting. We will have a look.
  • ROCKFISH_UweROCKFISH_Uwe HamburgPosts: 101Administrator
    Hi @OneSpeed ! Thanks for reporting. I checked your discussion issue in the forum with mozilla firefox (windows 10/firefox 51.0.1). With a "member" forum user-role you should be able to post discussions in the bug reports category.

    The alpha and beta subcategories however are read-only and don't allow discussions anymore.

    Should you still have problems please contact me via PM.
  • ROCKFISH_HCKROCKFISH_HCK Posts: 562Moderator
    I cannot reproduce the issue. Did you use the small trash can icons to get rid of the binding first?
  • OneSpeedOneSpeed Posts: 4Member
    yes, I've tried every available combination of deleting the binding and rebinding to various keys. even if I fill both available kebind slots with junk keys it will still rebind to the next/previous weapon. and if there's a free slot in the keybind menu it will fill it back in and display it as bound to scroll-up/down.

    If you like I could take screenshots or record a video demonstrating it.
  • ROCKFISH_HCKROCKFISH_HCK Posts: 562Moderator
    If it's not to much of a hassle to take a video, that would be great. Maybe I misunderstood something.
  • OneSpeedOneSpeed Posts: 4Member
    edited March 2017
    hope this helps:



    I didn't narrate it, but as you can see from the equipment-ui up top changing my device/consumable also changes the equipped primary.
  • ROCKFISH_HCKROCKFISH_HCK Posts: 562Moderator
    OK, great! Thanks for the video.
  • ROCKFISH_HCKROCKFISH_HCK Posts: 562Moderator
    I still couldn't reproduce the issue. Maybe your ini file is broken.
    You can try to delete the keybindings file here:

    AppData\Local\RSG\Saved\Config\WindowsNoEditor\GameUserSettings.ini

    The game will create a new one next time you start the game with default settings. Then rebind the keys to your liking and let me know if it works for you.
  • OneSpeedOneSpeed Posts: 4Member
    That fixed it, Thanks.
Sign In or Register to comment.