Wrong vertical mouse position in fullscreen with task bar at the top

kervalakervala Kickstarter Beta Backer ES1, Space Dog Posts: 6
Hi,

I'm playing using Windows 10 - 64 bits in 1920x1080.

Since last update (0.3.0.29930), when playing in fullscreen, the mouse position in all menus is wrong. There is around 20 pixels offset from real cursor position. So when I click on an menu item, the item just before is selected.

When switching to windowed fullscreen, the mouse position is correct, but my task bar is visible and the bottom part of Everspace is truncated.

I suppose these issues arise because I moved my task bar in top (unlike most of Windows users who just let it by default, in bottom).

That's very difficult to play in these conditions and the bug wasn't present before :(

Please could you fix it ? Thanks :)

If you need more details to reproduce this issue, don't hesitate to ask, but I'm almost sure moving your task bar to the top is enough :)

Comments

  • kervalakervala Kickstarter Beta Backer ES1, Space Dog Posts: 6
    When I move my task bar to the bottom, I confirm there is no problem at all :)
  • GiraffasaurGiraffasaur Administrator, Moderator, Space Cat Posts: 1,110
    edited December 2016
    Hello @kervala , thank you for reporting. This is a known issue and the development team (or rather, Epic) will have a fix in a future patch.

    In regards to the solution, it appears you discovered the same temporary solve recommended by the development team:

    Hi, the buton offset is a known issue in the current Unreal Engine version if you have the task bar on the top or the left. Epic is working on a fix. Move it to the bottom for a workaround. I'm not sure if the crosshair not going outside if 16:9 area is a bug, we intentionally limit the crosshair to a certain "circular area" in the middle of the screen, no matter what the screen resoultion is. It would be cheating if you could aim further when playing in a higher aspect ratio than 16:9

  • kervalakervala Kickstarter Beta Backer ES1, Space Dog Posts: 6
    Thanks a lot for your reply :) Yes, I'll do that for the moment :)

    Good luck to Epic guys to fix it (it shouldn't be so hard, I fixed a similar case in the game I working on :p).
  • xKostyanxKostyan Common Alpha Backer ES1, Customer Posts: 13
    Hi, I am not sure if this is supposed to be fixed by now. I am on an Update 0.4.2.30747 and I do experience this exact issue Windows 10 - 64bit
  • GiraffasaurGiraffasaur Administrator, Moderator, Space Cat Posts: 1,110
    Hmmm, it was to my understanding that is should have been corrected; just did some tests myself and everything seems to be in order when I'm playing in either Windowed Fullscreen or Fullscreen modes (at 1920x1080) with the task bar either on the top, left or right sides. (I'm also on Windows 10-64bit.) I also have VSYNC and smoothen frame rate enabled, not sure if that impacts the scenario.

    What resolution and display mode are you using, out of curiosity?
  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    xKostyan said:

    Hi, I am not sure if this is supposed to be fixed by now. I am on an Update 0.4.2.30747 and I do experience this exact issue Windows 10 - 64bit

    Does it maybe fix itself after switching to windowed mode and then back to fullscreen? It should be fixed in the latest Unreal Engine (at least that's what they said).
Sign In or Register to comment.