strafe up wont work

sergey1710sergey1710 Member, Common Backer ES1 Posts: 14
My strafe up wont work in game, i've tried everything, reset the controls and switch strafe up with strafe down but i still cant use strafe up

Comments

  • ROCKFISH_HCKROCKFISH_HCK Moderator Posts: 579
    Hi! Sorry, seems like a bug. You can try to delete the keybindings file here:

    AppData\Local\RSG\Saved\Config\WindowsNoEditor\GameUserSettings.ini

    It will create a new one next time you start the game with default settings.
  • sergey1710sergey1710 Member, Common Backer ES1 Posts: 14
    Still not working sorry for the really late reply XDXDXDXD
  • sergey1710sergey1710 Member, Common Backer ES1 Posts: 14
    It seems to be really bugged
  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    Could you maybe post a screenshot (or screenshots) of all your keybindings? Which language is your keyboard in?
  • sergey1710sergey1710 Member, Common Backer ES1 Posts: 14
    Its in english I´ll show a screenshot. It seems to be hardbound to the key.
  • sergey1710sergey1710 Member, Common Backer ES1 Posts: 14







  • sergey1710sergey1710 Member, Common Backer ES1 Posts: 14
    edited April 2017
    It used to work before I changed the keys to my preference but after that it was just bugged. Still love the game tho, without the strafe up key it is really annoying in tight spaces but I´m used to it :D
  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    I cannot reproduce this - it works from me (and is definitely not hardcoded) - I'm guessing that you're trying to assign strafe up to a key that is already taken by something else - and the action for "something else" is consuming the input for strafe up.

    Please try the following:
    - Restore to defaults
    - Select Hover Up (left side, not the entry field) and press the trash can so that the action is empty
    - Select Hover Down (left side, not the entry field) and press the trash can so that the action is empty
    - Select Hover Up entry field and press Ctrl
    - Select Hover Down entry field and press Space

    - Check if ingame Hover Up/down is now inversed compared to the defaults - (strafe up should now work with "Ctrl" instead of the default "Space"

    Please let me know if that works. Which key is your preference for strafe up by the way?
  • sergey1710sergey1710 Member, Common Backer ES1 Posts: 14
    I've been trying this for a while and It still doesnt work. My prefered hotkey for strafe up and strafe down is E and Q. E is for strafe down which always works and Q is for strafe up which doesnt work. Each time I change the hotkey from Space bar to Q and I apply the changes, it will automaticly return to space bar, which doesnt even work. Restored it to defaults and it still doesnt work
  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    I'm really running out of ideas here. You will lose some resolution settings, but you could try deleting thethe AppData\Local\RSG\Saved\Config\WindowsNoEditor\GameUserSettings.ini file. This should definitely restore the defaults so you can at least use the space bar to hover up. I find this all really strange, as we don't have any other reports on the problem and we're unable to reproduce it. I could try setting up the controls like you prefer on my system and send you a GameUserSettings.ini file to replace yours and see if that works. But this will have to wait until I'm back at the office tomorrow.
  • sergey1710sergey1710 Member, Common Backer ES1 Posts: 14
    Will I keep my progress?
  • sergey1710sergey1710 Member, Common Backer ES1 Posts: 14
    I already tried that btw , try sending me the control settings
  • sergey1710sergey1710 Member, Common Backer ES1 Posts: 14


  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    @sergey1710 - Please copy both files from the zip into your appdata/local/rsg/saved/config/windowsnoeditor folder

    I have a feeling that the problem was that there somehow was a mismatch between GameUserSettings.ini and Input.ini

    Please let me know if it works

  • sergey1710sergey1710 Member, Common Backer ES1 Posts: 14
    edited April 2017
    Nice it works thanks man. Hard mode was kind of a challenge without strafe up but now its just easy hahaha
  • troopitroopi Member Posts: 83
    Sergey, you can always extend the keybindings with autohotkey.
    I use autohotkey with mine, instead of assigning new keys in-game. This way I can add more complex behaviours. (even dogfight random patterns, if you're crazy enough!)
Sign In or Register to comment.