VR not working for me

ES_7857ES_7857 Posts: 2Kickstarter Alpha Backer, Space Optimizr
Oculus Rift owner here. When I start the game in the Rift, I'm perpetually stuck in the black screen with the hourglass. Sound is playing through the Rift headphones though. Not sure what I'm doing wrong here? Should I start the game with a certain command line?

Comments

  • ChuggzChuggz Posts: 2Kickstarter Alpha Backer, Space Optimizr
    How do you start it in VR mode?
  • ChuggzChuggz Posts: 2Kickstarter Alpha Backer, Space Optimizr
    Ok, made sure that my rift was hooked up and steam VR was running and yeah, stuck on 'waiting for vrserver.exe' intermediate screen.
  • ROCKFISH_HCKROCKFISH_HCK Posts: 560Moderator
    Hi! At the moment, VR support is only ingame. Try to press 'o' ingame to toggle (May need some toggles to work).
  • ES_7857ES_7857 Posts: 2Kickstarter Alpha Backer, Space Optimizr
    Thanks! Will try this out later.
  • Killstr3aKsKillstr3aKs Posts: 12Kickstarter Alpha Backer, Space Booster
    edited April 2016
    I've tried pressing O while ingame, both in first and third person but it does nothing. Before I consider this a bug, do I need to have a Rift connected for the toggle to work? I currently own a Vive so that might be the problem.
  • ES_10896ES_10896 Posts: 1Common Alpha Backer, Space Dog
    I too am a Vive owner. I'll check out VR support in a few hours when I get off work.
  • ROCKFISH_HCKROCKFISH_HCK Posts: 560Moderator
    Hmm.... I got it working with the Rift and the Vive. For the vive, you may have to NOT enable VR mode in Steam, then press 'o' ingame. If it's still not working I will take a deeper look into it in the next days.
  • Killstr3aKsKillstr3aKs Posts: 12Kickstarter Alpha Backer, Space Booster
    So I managed to start the game in VR. I just placed one of the base stations on my desk, set it to channel A and then started the game without having SteamVR running. After pressing 'o' the game actually switches to VR mode, however I don't get any tracking and the headset screen is just gray.


  • RejakuRejaku Posts: 4Common Alpha Backer, Customer
    edited May 2016
    Working for Vive:
    Within Steam, in the game's properties, uncheck "Use Desktop Game Theatre"
    Launch Steam VR
    Launch the game and get into the game, 1st person
    Press o
  • KisaiKisai Posts: 8Kickstarter Alpha Backer, Space Optimizr
    so its work fine with HTC vive ?
  • jabbajabba Posts: 6Common Alpha Backer, Common Beta Backer, Customer
    Rejaku said:

    Working for Vive:
    Within Steam, in the game's properties, uncheck "Use Desktop Game Theatre"
    Launch Steam VR
    Launch the game and get into the game, 1st person
    Press o

    Thanks Rejaku. Very helpful. Keep rocking on ACG chin wags.
  • RejakuRejaku Posts: 4Common Alpha Backer, Customer
    edited May 2016
    Kisai said:

    so its work fine with HTC vive ?

    Also just verified the same steps work for the DK2. Don't have a CV1, but I assume it works just the same.
    Crosshair is the only working HUD element in VR, tutorial popups and the menu are not compatible yet.
    jabba said:

    Thanks Rejaku. Very helpful. Keep rocking on ACG chin wags.

    Small world is seems, and I'm planning to.
  • Merlin HartleyMerlin Hartley Posts: 2Kickstarter Alpha Backer, Space Optimizr
    Also works okayish on OSVR with these instructions
Sign In or Register to comment.