Game won't start 0x000007b (Missing .dll)

PacTrainPacTrain Member Posts: 1
edited September 2016 in HARDWARE & SYSTEM (ES1)
Hi there,

I just bought your game on Steam, downloaded it etc.
So after I installed the whole thing, it didn't start. Steam says it is launching the game, then nothing happens. I tried launching it directly with the .exe, but then it just wants me to install DirectX Runtime again. (Yes I uninstalled and installed it again, several times). So I tried the "RSG-Win64-Shipping.exe", then I got an "0x000007b" error. Because I know this error from games like "Dying Light" and "Far Cry 4", I scanned the "Shipping.exe" with the Dependency Walker. There it showed me, that I have Installed the x86-Versions of "X3DAUDIO1_7.dll" and "XINPUT1_3.dll" instead of the x64-Versions. So I downloaded the 64-bit Versions of the .dll's and wanted to replace them, because I think, that's the problem, why my game won't start. Now my question: Where do I find these .dll's I want to replace? Seriously I can't find them anywhere on my PC.

If you're interested, my specs are:
Win10 Home
16GB RAM
Intel(R) Core i7-4770K
Nvidia GeForce GTX 970

Hope you can help me,
best regards,
PacTrain

edit: found the problem, just replaced the .dll's in my system32 folder and it works now, good game btw. :#

Comments

  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    Glad you were able to sort it out!
  • khushi1khushi1 Member Posts: 2
    If the dll file is missing then solution is here to download missing mfc100u.dll file. You can easily download the file .
  • ncowanncowan Member Posts: 1
    Hello,

    I have been reading everything I can find about Kerbal Space Program and crashing. There are NUMEROUS threads about it over the last FOUR years, but nothing in any of the threads here, or on Steam, or various reddits have done anything to fix the problem.

    I run the 64bit version. I have 64bit Windows 10 Home Edition. I have an Intel Core i7 2.6Ghz CPU. I have 16GB of 1600mhz RAM. I have an NVIDIA Geforce GTX 980M with another 4GB of RAM.

    My rig can run Skyrim or Fallout 4 with pretty much maximum graphical settings without regular crashing and with smooth gaming.

    The graphics in KSP are nothing to write home about, so the total lack of stability is pretty sad.

    Now, I DO run about 100 mods, but I get them through CKAN and they are installed properly and with very few exceptions they are of the appropriate version to match the 1.4.3 KSP version I am running. The handful that are a for an earlier 1.4.x, I asked in the corresponding thread if they are compatible and the answer was yes.

    Despite this my game was regularly crashing after trying to return to or exit the VAB/SPH after a flight. After leaving and entering the ship building buildings several times my game would crash. Since the game takes about 10 minutes to load with a lot of mods, waiting for it to load over and over to play for about 5 minutes is pretty -BEEP- tedious. I was spending more time watching the loading screen than playing the game.

    I have about 20 crash.dmp files that I have no way to open or read myself and taking the time to zip them with the Output_log, error log, and KSP log files and then uploading them to dropbox to post a link here... and then get no response from any of the Devs is obviously not worth anyone's time.

    So I did my best to try to solve this on my own....

    Out of all of the Error reports generated with the crash.dmp files my RAM was averaging 50%-60%, but despite this Linuxgurugamer suggested I was running out of RAM or my RAM was bad. I put Memtest86 on a USB drive and ran multiple passes.....my RAM is not bad and has no errors. Since more then half of it isn't being used by the game or the mods, I don't understand how I could be running out of it. I don't have anything else running in the background. I disabled all my Windows startup processes.

    I've tried forcing OpenGL, DirectX11, and DirectX12. It crashes with all of them. When I use OpenGL I get an additional module/file listed in the error report:
Sign In or Register to comment.