Can I improve Everspace's performance on my laptop?

ES_9423ES_9423 Posts: 1Kickstarter Backer, Space Cat
Hi,

I know I don't have a proper gaming machine but bare with me for a moment :)

MacBook Pro (Retina, 13-inch, Mid 2014)
3 GHz Intel Core i7
16 GB 1600 MHz DDR3
Intel Iris 1536 MB

Everspace performs very poorly on this setup, even with the lowest resolution and quality settings. I get a lot of stuttering in both video and audio. So it's practically unplayable.

However I manage to play other games with reasonable performance (Tomb Raider, Portal 2), so I'm wondering if it's not a configuration issue.

Is it expected that I get such a bad performance in my setup?
If not, is there any configuration file I could edit somewhere to improve the performance?

Thanks!

Answers

  • mugsymugsy Posts: 30Customer
    edited September 2016
    I have not had performance problems on any of the 3 computers I have tried.
    it was a little sluggish on the frame rate on my work computer, and its a 3.3 Xeon with a Quadro K600 4Gb.

    I imagine that you have all available settings in your computer set to performance instead of quality?

    your main problem will be that the game is likely to rely in some capacity on the video card to share calc load with the CPU and your CPU is also your video card... as for the rest i couldn't say, can be any number of configuration issue with your system rather than the game.

    I saw in the locked alpha/beta forums that people were able to edit config files when they had trouble but it appears this is not possible on the current release.

    you can still try a few things;
    -Set all game settings everything as low as possible
    -Make sure the system (not the game) graphics settings are set in high performance modes where possible
    -Try and find a setting to force disable vsync and anything to do with buffering (if your video drivers allow disabling anti aliasing do that too), should help alot with framerate with lots of asteriods in view
    -Exit any programs that are not necessary to run your computer ie active protection and scanning software (my machine runs upgraded Spybot S&D and its live protection mode chunks the heck out of system performance even on my big rig), laptop manufacturer bloatware
    -Update your video drivers
    -Lower the resolution if you get desperate
    -If all else fails try raise the process priority a little in the task manager (**WARNING** This may be unstable! Someone from the devs here might chime in and tell you its a BAD idea. It is entirely possible to fry your laptop if it does not crash when temperatures rise too high.)

    You also might just need to wait until later in development where some of the code causing your problems is optimised some more... remember this is early access.

    Cheers,
    mugsy
  • ROCKFISH_AndiROCKFISH_Andi Posts: 1,009Moderator
    I'm afraid that Unreal Engine 4 does not perform as well on Mac as on PC as far as we can tell. We currently don't have too many Mac players and data on "weaker" machines. Works fine in the office, but we're using a rather new iMac here. You could try turning vsync and smoothen frame rate in the options menu off. And maybe try switching off the music, too. I hope that any of this helps... I think we'll have to do a lot more performance optimization for Mac, though. Very sorry about this, but we've been so busy with preparing Early Access in the last few weeks that we certainly neglected the Mac port a little.
  • MintakaMintaka Posts: 1Member
    I just bought the game today. Very impressive!

    Anyhow, I noticed the default Display setting preset is set to "Epic". I turned it down to Medium, and the game runs much better. High was a bit laggy, and Epic was just out of the question.

    I am running:
    • OS X El Capitan
    • 2.2 GHz Intel Core i7
    • 16 GB 1600 MHz DDR3
    • Graphics: Intel Iris Pro 1536 MB
Sign In or Register to comment.