macOS 10.12 Sierra Logitech gamepad F310 not registering LT for acceleration

I’m on a MacBook Pro Mid 2015 model running macOS Sierra (10.12).

Everspace version

Logitech F310 gamepad

The left trigger for acceleration doesn’t register. Every other button does. I’ve tested the gamepad against other games and within the system itself (gamepad companion application) and the left trigger definitely works. Even tried a second brand new gamepad which also works in other games.


  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    Eeek that's weird, sorry about that. We'll have a look
  • rowanrowan Member Posts: 1
    This is still a problem and affects PS3 controllers as well:
  • DaaVDaaV Member Posts: 2
    Any updates regarding PS3 pad bug? Still doesn't work on my Mac OS Mojave :(
  • ROCKFISH_AndiROCKFISH_Andi Administrator Posts: 1,317
    DaaV said:

    Any updates regarding PS3 pad bug? Still doesn't work on my Mac OS Mojave :(

    Hi, I assume that you are the same person who wrote on the Steam forums, we gave the following answer there:

    Hi there, I just checked this out and this turns out to be an engine issue with the version of Unreal that we're using. Unfortunately, we're using a vanilla version of the engine on Mac, and it will take a while before we might get this fixed, if we will at all. But there are currently two ways around this problem:
    - You could customize your inputs and map the forward thrust to a button that isn't used as often, such as backward thrust or changing the camera view.
    - The better option is probably to use an emulation software like ControllerMate, such as described in the second reply here:

    Hope this helps!
  • samwyattsamwyatt Member Posts: 1
    You may consider using an emulation software like ControllerMate to fix the issue.
    geometry dash
  • bukaqefubukaqefu Member Posts: 1
    edited March 19
    Still doesn't work on my Mac OS Mojave
Sign In or Register to comment.