Installation Troubleshooting

ROCKFISH_SvenROCKFISH_Sven Posts: 91Moderator
edited September 2018 in Technical Support
Things you can try:
(If you get an error message about some missing .dll then jump directly to step 4)
  1. Restart your computer (yes, do it!)
  2. Install latest graphic drivers (Windows) or latest macOS Updates (Mac).
  3. Start the game without Steam and with admin rights - it will probably still not start, but you might get an error message:
    In your Steam library rightclick on EVERSPACE => Properties => Local Files => Browse local files => Rightclick on Everspace.exe => Start as Administrator (or Everspace_32bit.exe for 32bit Windows systems).
  4. Install prerequisites manually and with admin rights - might solve the problem or at least give you an error message:
    In your Steam library rightclick on EVERSPACE => Properties => Local Files => Browse local files => Go to Engine\Extras\Redist\en-us\ => Rightclick on UE4PrereqSetup_x64.exe (or _x86.exe for 32Bit Windows) => Start as Administrator.
  5. Make sure all necessary dependencies are installed:
    Win 7/8:
    Please go to Start => Control Panel => Windows Update => Check for updates => Install all available updates, including optional updates(*). After the updates are installed, restart your computer. After the restart repeat this step until no more updates are available.
    Also have a look if there are any updates listed in the "Restore hidden updates" category. If so you have to solve this problem first.
    If "Searching for updates" seems to be stuck you should also have a look at this known issue with Windows Update here.

    Win 10:
    Open the Windows Update Menu by pressing 'Windows-Key' + 'I' => Update and Security. Have a look if there are any issues reported on that menu or in the sub menu "Show Update History". If so, please try to fix these issues before you continue.
  6. If you do NOT get an error message when starting the game, see if there are helpful informations in the clipboard. Sometimes you still get an error message in the clipboard. Start the game without Steam and with admin rights (see step 3), wait till it crashes, open a text editor and press 'Ctrl'+'V', to see if you have an error message in the clipboard.
  7. See if there are helpful informations in the log files:
    Windows: Press 'Windows-Key' + 'R' => Enter %localappdata% => Press Enter => Go to RSG\Saved\Logs
    Mac: Open Finder => Press 'Shift+Cmd+G' => Paste ~/Library/Application Support/Epic/RSG and see if there is ia folder Saved/Logs
    open the latest .log files (if there are any).
    On Mac please also try to start the game from the terminal and see if you get some info outputted there: Start a terminal (ctrl+space => Terminal) => enter ~/Library/Application\ Support/Steam/steamapps/common/EVERSPACE/RSG.app/Contents/MacOS/RSG -windowed
  8. If you still can't start the game please
    1. Create a new thread in the technical support subforum
    2. Write the result of *every* step (e.g. what EXACTLY happened, when you tried to install the prerequisites)
    3. Copy every error message you get in the process. Even if you can't mark the text you can still usually copy it by pressing Ctrl+C. We want the exact message! Unfortunately we see a LOT of typos when people transcribe version numbers or file names and it is very hard for us to guess what the actual version/name is. If there is no message have a look in the clipboard and the logs (see steps above). If you still have nothing write explicitly in your post , that you have no error message and nothing in your clipboard and logfiles.
    4. Specify operating system, including if its 32 or 64bit
    5. Specify your game version (if possible) and were you got it from (Steam, GOG, etc...)
    6. Specify your graphics hardware. For Mac users: Also specify your Mac model (click on (apple) => About this Mac).
    7. Also mention things you can think of, that are unusual about your computer, e.g. if you are using a six monitor setup.

      We know this can consume some time, but please understand we can't help you if we only get "Tried everything, please help!"

We recommend to *NOT* add or replace single dlls manually in your Windows installation, as you can easily turn your system into a state where Windows thinks you have version A of some SDK while (only) some files have version B. Identifying dependency problems becomes very complicated from then on. This might have been a necessary move sometimes ten years ago, but nowadays *all* required dlls are available as part of some distributable packages with installers. If you miss a dll, find out to which distributable package it belongs to and install the complete package. Don't copy just a single .dll from the package.


(*) Of course you don't need updates like "Windows Defender Update" or Network adapter drivers, but unfortunately we can't provide a complete list of all really necessary dependencies. If you are trying to install only the absolute minimum then start with "Update for Windows X for XXX systems", updates for C++, VC and .NET, including the "optional" updates - but you're on your own with that - the easy way we recommend is to just install all recommended AND optional(!) updates.


Greetings
Sven

Comments

  • ydavrosydavros Posts: 2Member
    Hi! First let me say, I have been following this game's development for a long time, and I'm super excited to play. The problem is, my game won't start :( It gives me an error message telling me that I am missing "Microsoft Visual C++ Runtime", and gives me the option to install. When I follow the instructions to install, it still gives me the same error message. I tried installing the required files manually from the windows website, but it gives me another error message saying that those files are already installed. It's almost like the game can't see them? Please help! I really don't want to get a refund, I want to support your amazing work! I'm running Windows 8.1 64 bit. Hardware is all custom built for gaming, NVIDIA Geforce GTX 970, etc. I've tried the steps above but with no luck. Hope to hear back soon.
  • ROCKFISH_SvenROCKFISH_Sven Posts: 91Moderator
    ydavros, have you worked through all the steps above (you can probably skip the graphics driver for now) ?
    If this didn't help you could try to uninstall the C++ Runtime and then run the prerequisites installer again. If this still doesn't work, please tell us which OS you're using, if any C++ Runtime version number is shown during install and which C++ Runtime version number is shown when you open the "installed programms and features" box in windows.

    Regards
    Sven
  • goldmuskgoldmusk Posts: 1Member
    i just try all of the step but still not working and when i try the .exe theres some word
    EVERSPACE.exe - entry point not found " the procedure entry point terminate could not be located in the dynamic link libary C:\Windows\SYSTEM32\VRUCNTIME32140.dll"
    i just download the vcruntime140.dll and put it in the system32 and still happen
  • ROCKFISH_SvenROCKFISH_Sven Posts: 91Moderator
    edited September 2016
    Hello goldmusk,
    We do *NOT* recommend to manually replace single dlls in your Windows installation, as you can easily turn your system in a state where Windows thinks you have Version B of some SDK while (only) some files have Version A. Identifying dependency problems beome very complicated from then on. All required dlls shoud be available as part of some distributable packages with installers.
    • Please create a new thread in "Technical support" describe your problem and write your specs, especially your Windows version, including if its a 32 or 64bit Windows, the game version and where you got it (Steam, GOG,...)
    • Please also paste the EXACT error message. A helpful trick: Although often you can't mark the text of an error message, you can almost always still copy it by pressing ctrl+C while the error message windows is active, and paste it somewhere with crtl+v.
    • Have you seen any error messages while manualy installing the prerequisites?
    • Are you definitely sure the "Restore hidden updates" list is empty? (see step 5)
    Regards
    Sven
  • plopertplopert Posts: 2Member
    edited October 2016
    I'm having the same problems as ydavros. I also have win 8.1 64bit. I installed all the windows updates (except skype, silverlight, and a driver for my keyboard). I even checked to make sure there were no hidden updates. When i try to run the application via the local files as an administrator it tells me I'm missing microsoft c++ runtime and asks me if i would like to install it. When i click yes the UE4 window opens and i click uninstall. Run the application from local files again. Reinstall from the UE4. Run the application again and the same error pops up telling me C++ runtime is missing and asks if i would like to install it. Restarted my computer after updates. Even uninstalled and reinstalled EVERSPACE a number of times.

    Microsoft Visual C++ 2015 Redistributable (x64) - 14.24212
    Windows 8.1
  • ROCKFISH_SvenROCKFISH_Sven Posts: 91Moderator
    edited October 2016
    Hi plopert
    plopert said:


    Microsoft Visual C++ 2015 Redistributable (x64) - 14.24212

    Our Win 8.1 Pro test system has 14.0.23026. As far as I can see this is the same version that is shipped with EVERSPACE™ and when I download the Redistributable from Microsoft I get 14.0.23026, too.
    1. Where exactly did you see this number?
    2. Is this really the exact number or is it saying: 14.0.24212?
    3. Could you be even more specific about your Windows Version... is it Home edition or Pro or something else? (Just press 'Windows key' + 'Pause Key')
    4. Could you paste us the EXACT error message you get when starting the game (ctrl+c usually works even if you can't mark the message)
    5. Could you create a shortcut to the x64 prerequisites (just drag and drop with right mouse button), rightclick it => properties => in the line "Target" add " /log logfile.txt" (without the quotes, but with a space before /log), then run it two times (first time to uninstall, second time install) and then PM me the created .txt files (should be logfile.txt and logfile_0.txt or something)
    Regards
    Sven
  • plopertplopert Posts: 2Member
    I JUST NOW GOT IT TO WORK!

    ooops i mistyped it IS 14.0.24212. I found this number via control panel > programs and features. Nothing happens when I press the windows + pause/break key so I went into control panel>system and it just says windows 8.1. I then when into the system 32 folder and opened the licence rich text document and even there it just says 8.1. I'm assuming that means basic or standard.

    okay the way i got it to work was by removing microsoft visual c++ version 14.0.24212 and then installing 14.0.23026 (otherwise it wouldn't allow me to install 14.0.23026) once i had the old version installed it the EVERSPACE application just opened as it should. I can't wait to play this.
  • ROCKFISH_SvenROCKFISH_Sven Posts: 91Moderator
    Hi rrz9872
    Please do *NOT* replace/add single dlls. They always belong to a package - you should always install the complete package!
    In your case it belongs to "Microsoft-Software Visual C++ Redistributable for Visual Studio 2015". Have a look at ("programs and features"), see if it is there or not. If yes which version?
    I added a step 7 in the first post, please run through it!
    Regards
    Sven
  • SteamBrainsSteamBrains Posts: 72Space Cat
    I am on a Mac. OS Sierra (just updated)
    Hello. I have been trying to get Everspace to run for quite awhile now. I got to play it for a day in the beta, it was amazing. Then came back the next day, booted it up and crashed my whole computer. (Osx El Capitan) I did not get it to run until the early access.
    Miraculously during the early access update, It was fixed. I played that for a straight week, until out of nowhere, I came back to boot it up again, and it crashed my whole computer. I have tried uninstalling, reinstalling, deleting the saves manually, restarting my computer, and now updating to OSX Sierra. It still wont work. If anyone has any ideas, I would love to know. because the game is great, I love it, I JUST WANT TO PLAY IT.

    Btw when its running, it runs beautifully, the frame rate is wonderful, even on high graphics.
    Its a great game, your all great devs, I can send you video of what happens, crash reports (If you remind me how) :/ anything you need, I just need a bit of help.
  • ROCKFISH_SvenROCKFISH_Sven Posts: 91Moderator
    Hi SteamBrains,
    I added information about where to find log files on Mac in step 6 of the front post.
    Please work through steps 2, 6 and 7 and we'll see if we can help.
  • SteamBrainsSteamBrains Posts: 72Space Cat
    @ROCKFISH_Sven I feel like im messing up something when trying to access the log files -bash: /Library/Application\Support/Steam/steamapps/common/EVERSPACE/RSG.app/Contentents/MacOS/RSG: No such file or directory
    Is it possible to elaborate on the commands a bit? If there's another way to bring up crash reports that would be great too. It seems to be problematic because when it crashes I have to shut down the whole computer, so im not sure how complete the report will be. As for step 2, everything is up to date
  • SteamBrainsSteamBrains Posts: 72Space Cat
    @ROCKFISH_Sven whatever that last update was, it was magical. EVERSPACE is running again, and it's still as beautiful as ever. I've been playing it a ton (again) and I'll send feedback soon, thank you so much, you guys are the best!
  • zolla2000zolla2000 Posts: 1Member
    i cant lanch this game
  • ROCKFISH_SvenROCKFISH_Sven Posts: 91Moderator
    Hi zolla2000,
    please work through the first post in this thread. As far as I can see, it is highly likely this will solve your problem.
  • flowmezflowmez Posts: 5Member
    edited June 2017
    I registered my self only to make you know, i solved my problem with EVERSPACE x64 exe start. Dont know how, but however i think this can be usefull for you, and hope for others.
    -Game doesn't star form steam (launches but nothing happens, and 5 secs later the game recloses on steam). windows doesn't reports any error
    -Gamez doesn't start from app or excel directory
    What did I do:
    1) Game didn't start from steam--> tried every recomended point with no results.
    --> when trying to start game and install UE4 manually from launch directory had the following issue: always, no matter if the drivers where already installed, the program advised me to install them, giving me later the choice of unnistalling (in the case they are already installed). After installing drivers nothing happens.
    -->This stopped to happen when i launched the exce file not from the app directory, but from the exe directory (RSG/Binaries/win64/"RSG-Win64-Shipping"). Now windows appears to be more concrete about the problem, telling me that had this 0x00007b problem that anyone appears to be able to resolve (at this point tryed again the points ont he list, with nor esults)

    2) Read from someone who had same issue, but could start RSG-Win32-Shipping file in his windows x64 .

    So, arranged with that solution, kept playing for two days with RSG-Win32-Shipping file instead of the x64 bits one.
    After trying x360ce on RSG-Win32-Shipping and obtain no results, just tryed the same process within the x64 exe folder (start x360ce_x64 exe at RSG/Binaries/win64, configure gamepad adding xinput file to the same directory where exe game file is located and start game).

    Well, thats foking all. Just did that. When starting the game from the RSG/Bineries/win64 directory the game worked just fine and with the padcontroller (with the 32 bits version x360ce didnt work for me, and still dont know why, desintalled and reinstalled c++ redistribuitable versions and if its not because win 64 cant use that arquitecture it must be a game problem)

    Could be a matter of not recognising the pads controllers? and due to that and some visual c++ compatibnilities between wind10 and older versions the game stops launche and reports the 0x0007b error? Like if the laucher keeps requiring the controller drivers for gamepad and not obtaining them shuts down the launch.
    Hope this is usefull.
  • flowmezflowmez Posts: 5Member
    edited June 2017
    Did everything. Game still doesnt launch on 64 bits version, but it does works on 32 bits.
    But, solved it. Dont know why.
    How: after trying to use x360ce with the RSG-Win32-Shipping file and obtain no results, tryed same thing with x36ce_64.exe and RSG-Win64-Shipping.exe directory file. Launch the game. Just fine.
    Now x64 works with the game pad (L)

    Why could this be? may be something about compatibility between win10 older versions and c++ redist? Like if the launcher waits untill it gets the pad drivers and not getting nothing shuts down the launch and reports the 0x00007b error.
    ps. the 0x0007b error was reported starting the game without pligging in the pad usb too.
Sign In or Register to comment.